Hue Emulation doesn't support Colorbulbs?

openhab2
hueemulation
yeelight
Tags: #<Tag:0x00007fe05e779430> #<Tag:0x00007fe05e779228> #<Tag:0x00007fe05e778fd0>

(Arno) #21

Another app, called “Hue switcher” is able to control color. This seems to be an incompatibility with certain controllers.

edit: this app is sending color commands to anything and everything, even my switches… :frowning:

So the emulation will accept color commands for my color lights, however my echoes don’t recognize the lamps to have color capability.

BTW I am on the latest nightly. Just updated today in hopes of fixing this, since I saw there was some development for color lights lately.


(David Graeff) #22

That’s super strange as I’m using the same app for controlling my colour bulbs and the debug output looks good. If you remove the “?debug=true” part, you will see what Alexa sees. And the emulated light should be an extended color light, as stated in the debug out.

I know that Echos might have problems, depending on the firmware. Some devices just don’t have firmware support for colors.


(Unparagoned) #23

It’s all a bit confusing but the way I understand it is the Hue Emulator does NOT have local Alexa color support. I think the reasoning was that Alexa isn’t suppose to be able to control color bulbs locally, even though it can is a few regions. So you need to use a cloud based app/proxy, so the Alexa can sent the color command on-line to, which would then send a command to the hue emulator. I have all my items exposed to my smartthings hub, so I just added the smartthings app to alexa and now I can control the color.


(Arno) #24

I don’t think that is how it works, because the android apps don’t know there are echoes in the household, nor do they know how these can be addressed through the cloud. i.e. what my account name is.

I also find it very peculiar, that in spite of using the same app (which is not market specific like alexa), there still is a difference in functionality. Don’t have any explanation for that right now. Even checked Karaf for the bundles, but it only lists one hue emulation, which carries 23rd of january as the version date. The output of the emulation seems ok, but it seems to be something in the interpretation of that output that causes things to not work. As input-wise, it does work with the app that doesn’t care about capabilities. Maybe there is something cached in the echoes? I have deleted and discovered multiple times though, always with the same result.

It works through myopenhab, but I would prefer to use Hue emulation, since that takes one server out of the mix to operate my lights. I do appreciate the efforts in providing myopenhab very much, but compared to the also needed alexa servers, the stability is always going to be a lot less.

The workaround with the echo binding is a neat trick that will probably allow to do almost anything through alexa, but I don’t like that binding because it uses scraping in stead of an API. As I am looking for maximum reliability, I am not too convinced with that.

If I don’t get this to work, I might use some extra items with custom tagging to make sure I can use the emulation for on/off , and use myopenhab for the rest.


(Flole) #25

Keep in mind that some devices require XY Color Support and that did not make it in 2.4.0 Release unfortunately, it should be in 2.5.0M1 though (I haven’t verified this though, I did not even check the release notes if it’s mentioned there)


(Arno) #26

This is the raw output for the light above

"12":{"state":{"hue":8192,"sat":102,"xy":[0.0,0.0],"effect":"none","transitiontime":0,"colormode":"hs","bri":127,"ct":500,"on":true,"reachable":true,"mode":"homeautomation","alert":"none"},"type":"Extended color light","modelid":"LCT010","uniqueid":"edd6f7b1-244a-437e-9035-2050239e698a-12","manufacturername":"Philips","swversion":"1.15.2_r19181","swconfigid":"F921C859","productid":"Philips-LCT010-1-A19ECLv4","friendsOfHue":true,"colorGamut":"C","hascolor":true,"name":"Stehlampe","config":{"archetype":"classicbulb","function":"functional","direction":"omnidirectional"},"capabilities":{"certified":true,"streaming":{"renderer":false,"proxy":false},"control":{}}}

(David Graeff) #27

Looks alright. At least 3rd party apps should recognize this as color bulb.
And yes with 2.5M1 Hue emulation also supports XY colors, but that was never necessary for my Echoes.

Have you checked the “whitelist” as well? Because the Alexas should appear there.

And one difference we have on our setup is indeed the port. Maybe Echoes classify openHAB as fake-hue-bridge if not on port 80 and disable color support. Who knows.


(Arno) #28

Today another look, everything changed. Previously, I had deleted all the lights from my echo app, and it only discovered the ones from Hue emulation immediately. But I also have myOpenHab running. I played around with the tagging to see whether it would help with HueEmulation, but after giving up, I changed things back to “Lighting”

Today I wanted to try out a workaround to control color by myOH and additionally have switching capability via HueEmulation. Thus I started the alexa app, and the lights were also there from myOH. Then I looked at my HueEmulation lights, and lo an behold, I could now control color in the alexa app. And alexa would now take color voice commands!

I really don’t know what changed, other than that alexa seemingly added the myOH lights overnight without me asking for it.

Then I checked the Hue Essentials app, and found color control at a place where I didn’t look before. Yesterday I tried tapping on the slider. Today I tapped the name and got a color dialog. So maybe I spoke prematurely that Hue Essentials didn’t recognize the lights as color lights. Maybe it just was alexa after all.

As a test, I removed a now correctly recognized light. On rediscovery, it was now discovered correctly in both the HueEmulation and myOH versions. I am absolutely sure yesterday I had no color capability: “not supported” on voice command, no color dialog in the alexa app, and no color capability in the lamp details in the alexa app. Today it is there, and all three spots recognize color where there was none yesterday. I don’t have any reasonable explanation for this. Maybe there was some kind of cache in the Echo devices, containing settings from a time when the emulation didn’t support color, which was updated over night?


(David Graeff) #29

Yes they do have a cache. When I changed from an original Hue bridge to Hue emulation it took me three hours and the Amazon support hotline to make my Echos forget my old devices. I thought that is fixed by now.


(Arno) #30

That would explain it.

I now have irregular behavior from my alexa room group, turning random lights off in stead of setting them to a color. They do what I want individually though. I’ll wait another day before I spend any more time on that :slight_smile:

Anyway, together with the zigbee binding, the hue emulation makes OH into a far superior hue hub than what Philips makes. Thanks to David and @chris for providing these bindings.


(Mike Major) #31

I added my lights using hue emulation a couple of weeks ago as I got tired of the frequent timeouts using myopenhab. I had my lights exposed using both the hue emulator and myopenhab, but the hue ones would not accept colour commands from Alexa. Alexa would use the local hue for simple on/off and use myopenhab for colour. Colour commands would not work when myopenhab was disconnected.

Just checked now and the hue lights are showing as supporting colour and Alexa can change colours even when myopenhab is disconnected :grinning:

This has changed without any changes to my openhab setup.


(David Graeff) #32

So that means Amazon updated the local Hue support recently. Very nice. Hopefully for all countries and not just selected ones.