Hue Emulation doesn't support Colorbulbs?

openhab2
hueemulation
yeelight
Tags: #<Tag:0x00007f51ea7ce640> #<Tag:0x00007f51ea7ce438> #<Tag:0x00007f51ea7cdec0>

(JustAProgrammer) #1

So I Managed to get all of my Bulbs and Yeelights into a Color item as gColor and exposed to Alexa via Hue Emulation:
Alexa SmartHome Devices:


.items:
Yeelights:

Color Yeelightc_1 "Farbe" (gYColor, gYBrightness, y1)              {channel="miio:basic:XXXXX:rgbColor"}
Color Yeelightc_2 "Farbe" (gYColor, gYBrightness, y2)              {channel="miio:basic:XXXXX:rgbColor"}
Color Yeelightc_3 "Farbe" (gYColor, gYBrightness, y3)              {channel="miio:basic:XXXXX:rgbColor"}
Color Yeelightc_4 "Farbe" (gYColor, gYBrightness, y4)   {channel="miio:basic:XXXXX:rgbColor"}
Color Yeelightc_5 "Farbe" (gYColor, gYBrightness, y5)              {channel="miio:basic:XXXXX:rgbColor"}
Color Yeelightc_6 "Farbe" (gYColor, gYBrightness, y5)          {channel="miio:basic:XXXXX:rgbColor"}
Color Yeelightc_7 "Farbe" (gYColor, gYBrightness, y7)  {channel="miio:basic:XXXXX:rgbColor"}

Arilux AL-CO1:

Color Arilux2_c "Farbe auswählen:"(gAColor, gABrightness, g2)  {channel="wifiled:wifiled:XXXXX:color"}
Color Arilux3_c "Farbe auswählen:"(gAColor, gABrightness, g3)  {channel="wifiled:wifiled:XXXXX:color"}
Color Arilux4_c "Farbe auswählen:" (gAColor, gABrightness, g4)  {channel="wifiled:wifiled:XXXXX:color"}
Color Arilux5_c "Farbe auswählen:" (gAColor, gABrightness, g5)  {channel="wifiled:wifiled:XXXXX:color"}
Color Arilux6RGBW_c "Farbe auswählen:" (gAColor, gABrightness, g6)  {channel="wifiled:wifiled:XXXXX:color"}

Groups:

Group:Color:AVG gColor "Gruppenfarbe" ["AlexaColor"]
Group:Color:AVG gAColor "Gruppenfarbe Arilux" (gColor)
Group:Color:AVG gYColor "Gruppenfarbe Yeelights" (gColor)

I am actually able to dim the brightness with the command “echo, dim -gruppenfarbe- to 20%”
But I’m not able to change color, everytime I say something like “echo, turn -gruppenfarbe- red” I get a response saying that my device doesn’t support this. Does someone know where this behaviour comes from?

And even tho the Color item is a On/Off Type I can’t turn them on/off through alexa:


(Scott Karns) #2

Have you read the documentation for the Hue Emulation binding? According to the doc you can tag a color bulb with “ColorLighting”, which Alexa should then be able to control as a color bulb.


(CM6.5 H102) #3

To go along with what @scottk mentioned you can use this link to check your Alexa/Google item tagging.:wink:
https://us-central1-new-assistant-test.cloudfunctions.net/connectionChecker


(JustAProgrammer) #4

Hey Scott,

  • Yes

(Scott Karns) #5

Details of your system would help here.

I am running up-to-date openHABian on an RPi 3B, openHAB release 2.5.0-S1493-1. I do not see that information when I open the Hue Emulation Binding dialog box:


(JustAProgrammer) #6

Let me know which one!
I’m running the latest OH version on a RPi 3b+

to rename the tags? just rename it, it’s a textbox.
But it didn’t worked at first too, when the Tag was called “ColorLighting” but I’m gonna try it just to be sure!
As I said, it gets detected but its not controllable like a colorlight …
Thanks for helping.

Edit:
renamed it to “ColorLighting”:
image

and it gets detected too:

But still the same Problem


(Scott Karns) #7

Unfortunately I have no color lights in my system, so I can’t run experiments here. @David_Graeff, is this a bug?


(JustAProgrammer) #8

no problem, thanks for helping!

If you need additional information, let me know! I want to get this resolved!
Thanks :slight_smile:


(David Graeff) #9

Do you use a group item for colors?
I have no idea if that works or is even supported by openHAB itself.
Single items work for sure, I have some in my system. You seem to have discovered them with Alexa as well.
Try also some Hue apps out for changing the color.

Cheers, David


(JustAProgrammer) #10

That’s the thing I’ve also thought about but weirdly it doesn’t work either.
I’ve dispossed a yeelight and one LED strip to alexa but still, can turn it off and send a brightness in percentage but nothing more or less.

Yeah worked very well!

some Hue apps? within alexa as a skill?

thanks for helping!


(David Graeff) #11

The official hue app (for your mobile) does not work to my understanding, because we haven’t reached the state of 100% emulating a hue bridge. But other apps work. Check out if they render the color item correctly and if they allow to change the color. If that works, you need to remove all of your Alexa items unfortunately and rediscover again.


Support for more Mi-Home Aqara items
(Arno) #12

I have the same problem. My color lights are emulated as dimmable lights. Tried an android app as well.

I have both tried adjusting the tagging and completely leaving the tag filters empty. However, I can’t get the lights to show up anything different than as a dimmable light.

I am using a german echo dot for the discovery.


(JustAProgrammer) #13

Ive managed to get everthing working like I wanted it to compare the strings with the channel “last voice commands”. works pretty good


(Arno) #14

I really don’t know what you mean by the channel “last voice commands”


(JustAProgrammer) #15

download the “amazon echo control” - addon and you will get a channel which parses the last voice command, therefore the last sentence you’ve said to your echo device as a string.
You can compare those within the rules and let some code run:
See my code: (but its jython on the jsr223 api)

    if event.itemState.toString().lower() == "pc an" or event.itemState.toString().lower() == "p. c. an":
        events.sendCommand(event.itemName.replace("lastVoiceCMD", "TTS"),"Wird gemacht chef")
        logVC.info("Jython: PC angeschalten")
        events.sendCommand("wol_rechner","ON")

(Arno) #16

How will this help making the hue emulation expose my lamps as color lamps in stead of dimmable lamps?


(David Graeff) #17

@Nico111 presented an alternative to control light bulbs, but honestly, that is more work. Let’s try get hue emulation running better instead.

Have you checked the documentation and followed the troubeshout section?


(Arno) #18

This page?


It is not very helpful. Says Openhab should run on port 80 or the emulation will not be discovered. My OH runs on 8080 (default) and is discovered, it just doesn’t see the lights as color lights. I can control and dim the lights, but it won’t control color.


(David Graeff) #19

Sigh. I’m taking about this one here: (This is just two lines down, man, seriously)

  1. Navigate with your browser to “http://your-openhab-ip/description.xml” to check the discovery response. Check the IP address in there.
  2. Navigate with your browser to “http://your-openhab-ip/api/testuser/lights?debug=true” to check all exposed lights and switches.

(Arno) #20

Sorry, but I thought that part of troubleshooting was still about checking whether the right port was set. I get the following representation for a color light from the emulation:

Stehlampe: Extended color light
	on: true, brightness: 127, hue: 8192, sat: 102, xy: {0.0 0.0 }, ct: 500, alert: none, effect: none, colormode: hs, reachable: true

Alexa won’t take color commands, the alexa app also doesn’t offer color, and the android app “Hue essentials” will also only see it as a dimmer.