Hue Emulation in 2.5.1 - Who has it working und how is your config?

I’m trying to debug my hue emulation after upgrading to 2.5.1 from 2.5M1 it stopped working.

If you have it running or have issues please help me by answering my short questions.

  1. Is it running without issues ?
  2. If you have have issues please give a short description or link to it
  3. Did you upgrade or fresh install 2.5.1?
  4. Are you running openhab on a Raspi, PC Linux or a Docker Image?
  5. On which port is running? 8080 ? 80 ?
  6. Are you using HTTPS ? Maybe through a reverse Proxy ?
  7. What is connecting to your hueemulation ? (Alexa, Logitech Harmony Hub, …)
  8. Do you have Dimmer Items using % values to control?

I would be very thankful for anyone answering any of the questions.

If you ha

2.5.0 running on a RPI3 works for me with both Alexa and Harmony hub. The only issues I have are with Alexa reporting errors even though OH has done what was requested. OH is running on port 8080 with port 80 redirected so that Alexa discovery works.

What are the state of your items in the Harmony hub app, are they on, off or offline? If they are offline have you tried putting the binding in pairing mode and repairing in the Harmony app?

I am running with in the issue of alexa responding to some commands saying it didn’t work but did. There is a github fix for this in the process of being released.

I had some issues transferring from the m1 version to the latest. To make it work I started over with a new openhabian install and added one binding at a time and configured my things.
This was the fastest way for me as the update path did not function for some reason. I was not able to use the backup and restore method. I had to manually place my config files for some reason.

I am using reverse proxy on port 80. I also deleted all the things from alexa one at a time and relearned.

Process summary.

  1. Backup config using openHAB cli backup tool, copy zip file some place safe.
  2. Make a new sd card with openhabian
  3. Boot sd card, once openHAB up and running
  4. Install bindings and copy config for each binding. Verify each binding works as adding.
  5. Once openHAB working have alexa discover devices.

This was a lengthy process but worked. My system is very stable and no issues.

1 Like

I can’t run it on port 80 but this was the same for the previous version.

I have to look how to get more information from the Harmony Hub App.
I didn’t need to rediscover devices when moving to 2.5M1 as I remember.

My items are discoverd by Alexa but without a type (Typ: Sonstiges).
But I can’t even control the items - unlike you.
So maybe it now needs to run on port 80.
Or it might be something using docker.

The help docs state that Alexa expects the emulated bridge on port 80. I can’t speak for any other devices but Alexa for sure.

I read a bit and it looks like a diffrent port might only work if using a gen1 echo device.
I have a gen1, but it still sound like it’s a worth try.

But it I can’t do it on the same hardware :confused:

Can’t you set up a second IP-address dir the device? I did it that way.

Hi again, I could not add a second IP as this was a NAS with a Docker on it, could only add IPs in different subnets. But it might have worked +1

So I did migrate to a Raspi4, but also moved from Openhab2 & Node-Red to ioBroker & Node-Red - most of my configuration is in Node-red so I took this step.

I’m using to emulate Hue devices now.
Which will work with openhab2, so I post it as my solution.

I control these devices from Alexa and from my Harmony Hub remote control (smart home buttons)