Hue Emulation showing a wrong IP Address

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Plus Rev 1.3 ARMv7 Processor rev 4/997124113089844
    • OS: Linux openhabian 5.10.17-v7+
    • Java Runtime Environment: OpenJDK Runtime Environment Zulu11.48+21-CA (build 11.0.11+9-LTS)
    • openHAB version: 3.1.0
  • Issue of the topic:

I started a fresh installation of 3.1.0 in oppose of migrating from 2.x.

Now I’m facing an issue with Hue Emulation, when following the instructions of openHAB Hue Emulation - System Integrations | openHAB and trying to check /api/status the IP address listed in the result ( is not matching the IP address of the RPI ( and therefore enabling pairing is failing by using the hyperlinks (if I copy the hyperlink and update the address apparently is working but the problem is that Alexa can’t discover new devices).

This is the result:

Self test

To access any links you need be in pairing mode!

Pairing mode: Off (V2) Enable | Enable with bridge V1 emulation

6 published lights (see
222 published sensors (see

UPnP discovery test

upnp announcement thread not running

|serial no|name|
|-- masked --|Roku 2|
|-- masked --|Philips hue (|

Reachability test


I was trying to check where the IP is coming from but couldn’t find any place. Everything: the ifconfig inside the RPI, the SSH (where I’m remoting to the RPI), my router’s console, etc., is indicating the correct IP is

Any clue why this IP address is showing?

Thank you

The doc says:

Navigate with your browser to “http://your-openhab-ip/description.xml(http://your-openhab-ip/description.xml)” to check the discovery response. Check the IP address in there.

What is returned in the browser ? It is shown in the section about port forwarding / reverse proxy so what you need to enter is http://your-openhab-ip:8080/description.xml

Yes, but still the wrong address:

<root xmlns="urn:schemas-upnp-org:device-1-0">
<friendlyName>openHAB Hue Emulation (</friendlyName>
<manufacturer>Royal Philips Electronics</manufacturer>
<modelDescription>Philips hue Personal Wireless Lighting</modelDescription>
<modelName>Philips hue bridge 2015</modelName>

have a look at openHAB Hue Emulation - System Integrations | openHAB there it is described that in a few cases it might be required to set discoveryIp manually.

The hue emulation service will announce its existence via UPnP on every of the openHAB configured primary addresses (IPv4 and IPv6).

Usually you do not want to set this option, but change the primary address configuration of openHAB.

This option allows you to override what addresses are used for the announcement. You can have multiple comma separated entries.