Hue emulation stopped working, all devices are of type "various" now

I am running openHAB 2.5.0.M1 Milestone Build and it worked great for the last couple of month. Then (I noticed it yesterday, but the problem might be a little older) all my devices stopped responding to Alexa commands. I can still control everything from Openhab but Alexa was not working.

Here is what I tried to fix it:

  • Restart openhab and the included hueemulation I am using
  • Removing all devices from the Alexa app and rediscovering them

Unfortunately it is still not working. All devices show up in the Alexa app but they are all of type various (“Sonstiges” in my german installation) now and there is not even an option to switch them in the app. Via voice control its not working either.

How can I fix this?

This is the output of my /api/description.xml

<root xmlns="urn:schemas-upnp-org:device-1-0">
<friendlyName>openHAB Hue Emulation (</friendlyName>
<manufacturer>Royal Philips Electronics</manufacturer>
<modelDescription>Philips hue compatible Personal Wireless Lighting</modelDescription>
<modelName>Philips hue bridge 2015</modelName>

Does anyone have any idea how to get this working again? It seems like I am not the only one who has currently problems with the hueemulation and this is a really important feature of a modern smarthome system

Can you confirm what version of openHAB 2.5m1?

I have issues with versions greater than 2.5m2. I posted and issue looking for detail to debug.

As of now my 2.5m1 version is working. Except for every now and then alexa saying in responsive.

Hey, what exactly do you mean with version of 2.5m1? Openhab console shows me the version “openHAB 2.5.0~M1-1 (Milestone Build)”.
I assume the plugin for hueemulation has the same version as I did not update anything manually here

@LastSamurai yes this is correct the openHAB version. Unless you force something the binding version matches.

I was trying to check if you were on a version that I had trouble with.

Well I am unsure what else to ask myself, let’s see if someone else chimes in.

I have the same problem. But I’m on openHAB 2.4.0-1 (Release Build). From one day to another no device was reachable in the Alexa app. I deleted all devices in the Alexa app put hue emulation in paring mode and let Alexa search for new devices. Devices are back again but have the type “various”.

Hello everyone,

I have the same problems described above since yesterday. I´m also using openHAB 2.5.0~M1-1 with the hue emulation plugin.

Alexa finds all the devices from openHAB with type ‘various’. But if I want to control them Alexa answers that the device is not responding.

Two days ago I had also problems to control my openHAB items with Alexa, but after searching in alexa web application for new devices (I did not remove them, just searching again), the problem was solved but I´ve no idea why.

It seems to me that something was changed from amazon site.

Another reason could be that I replaced an Amazon Echo 1st generation with an Amazon Echo 3rd generation just a few days ago.

Hello all, same problem here since two days. I have tried a Echo 3rd and a Echo 1st generation. OH 2.4.0. I tried to delete all devices in alexa and did a discover again, devices were found but declared as “Sonstige” (‘various’). Switching on/off from app not possible.

I have the same problems since a few days.
openHAB 2.4.0-1 stable.

I could imagine a update on the echo-devices caused this.
I tried the unlikely: contact amzaon support … let you know if I get an answer…

I wonder that I can rediscover all devices and than there is only a property page displayed and no possibility to switch them:

click on “Lights”

As I had these problems before I start thinking about using the Aamzon Echo Binding - lastVoiceCommand chanel… not really smart - but may be working more reliable?

… update: no usefull answer from the amazon tech support - they tried me to install the hue skill - that seems no solution.
I tried the openHAB skill on the Alexa before - slow reaction time :frowning:

I had the same problem with my lights showing in the Alexa app with various errors such as “device malfunction”, “device unresponsive” or “server unresponsive”.

I managed to solve it using the Alexa web UI.

Login to and find your smart devices. If your lights have a description of something like “royal philips electronics smart device” then it’s likely you are having problems.

  1. Using the web UI forget all your hue lights
  2. Wait a few minutes
  3. Rediscover devices from the web UI.
  4. Wait a few minutes
  5. Refresh the list of devices and check non have the description of “royal philips electronics smart device”. If any do then repeat the steps.

After 4 or 5 repeats of the above all my lights had proper descriptions such as “color light”.

Today, not the Alexa web ui nor the Echo is able to discover any new device.
http://openhabianpi:8080/description.xml is working as normal.

It’s getting worse for me, without changing anything to the openhab installation.

Some good/bad news:

As I mentioned above the new amazon echo device was the problem (I replaced an old amazon echo 1st generation with an echo 3rd generation).

Now I unplugged the 3rd gen. echo, plugged in the 1st gen. echo and everything is working fine as before.

Exited how long this solution will work (until amazon will update all devices)…

I only own gen 2 echo dots. Worked since 2017. And now something must have changed. Maybe a echo firmware update?

My “fix” worked for about 24 hours and now after forgetting the devices I can’t discover them again. It doesn’t look like any of my echo devices changed software version since it was working yesterday.

I deleted all devices, and reloaded them all.

I grabbed a pcap of the alexa attempting to change the light state - it appears that there was no attempt to change the state. Based on docs I have found there should be some call to:

PUT /api/username/lights/number/state

I’m wondering if they actually broke Alexa/Hue integration in general and not just for Openhab - I see multiple calls to

LOCATION: http://server:8080/api/description.xml

Redirecting port 80 to 8080 fixed the issue.

1 Like

I have to apologize:

As I wrote above I replaced a 2nd gen echo with my 1st gen echo (not a 3rd gen. echo), then problem was fixed…

I again deleted and re-detect all devices but still not working with alexa to switch on/off.


I have two Echos 2 nd Generation (Amazon Echo, Amazon Echo Dort).

I solved it for me:

Redirecting port 80 to 8080 seems to be part of the solution:
sudo iptables -A PREROUTING -t nat -p tcp --dport 80 -j REDIRECT --to-ports 8080

I then also set the “Optional discovery web port” in the hue emulation settings of OpenHab to 80.

After that I removed all smart home devices from alexa and let it search for new devices.
It’s now working again with these settings for me. Although I cannot control the devices from within the Alexa app.


Thanks a lot, worked well for me. I can control via voice again after performing your steps. Alexa App Hand Control is not working.