Hue Emulation Stopped Working Completely

My HUE Emulation completely stopped working yesterday for absolutely no reason that I can fathom. Alexa will not discover new devices and all Hue Emulated devices currently in Alexa say “Device is unresponsive”

If I go to my server at http://myopenhab/api/description.xml I can see all of my devices. The ip address is good, all looks well. I have tried uninstalling and reinstalling the binding, which did nothing.

My openhab server is on port 80 and 1900 is opened. Openhab version and binding are 2.5.11.

I tried setting up debug logging using log:set DEBUG, but I don’t see any additional logs.

I have spent hours on this and would love some help tracking the issue down. First thing that would help is how to get the DEBUG logs working for this binding.

I see a lot of folks saying to remove all devices from Alexa and discover them again, but I would really like to make sure this is only done when necessary.

It looks like I did get debugging to work. Here is some more information. I enabled pairing in Hue Emulation and ran discover devices. It seems as though Alexa is finding the devices

2020-12-28 15:08:18.148 [DEBUG] [ulation.internal.HueEmulationService] - REST request GET 2fec6024-99f5-458d-be72-c4bc4241e3d5/lights/80
2020-12-28 15:08:18.148 [DEBUG] [ulation.internal.HueEmulationService] - REST response: {"state":{"on":true,"reachable":true,"mode":"homeautomation","alert":"none"},"type":"On/off light","modelid":"Plug 01","uniqueid":"f87ee55d-e3bf-46d2-8c2b-1d044d70d38f-80","manufacturername":"OSRAM","productname":"On/Off plug","swversion":"V1.04.12","hascolor":false,"name":"Candle","config":{"archetype":"classicbulb","function":"functional","direction":"omnidirectional"},"capabilities":{"certified":false,"streaming":{"renderer":false,"proxy":false},"control":{}}}
2020-12-28 15:08:18.167 [DEBUG] [ulation.internal.HueEmulationService] - REST request GET 2fec6024-99f5-458d-be72-c4bc4241e3d5/lights/86
2020-12-28 15:08:18.167 [DEBUG] [ulation.internal.HueEmulationService] - REST response: {"state":{"on":false,"reachable":true,"mode":"homeautomation","alert":"none"},"type":"On/off light","modelid":"Plug 01","uniqueid":"f87ee55d-e3bf-46d2-8c2b-1d044d70d38f-86","manufacturername":"OSRAM","productname":"On/Off plug","swversion":"V1.04.12","hascolor":false,"name":"Rob\u0027s Garage Door","config":{"archetype":"classicbulb","function":"functional","direction":"omnidirectional"},"capabilities":{"certified":false,"streaming":{"renderer":false,"proxy":false},"control":{}}}
2020-12-28 15:08:18.219 [DEBUG] [ulation.internal.HueEmulationService] - REST request GET 2fec6024-99f5-458d-be72-c4bc4241e3d5/lights/87
2020-12-28 15:08:18.219 [DEBUG] [ulation.internal.HueEmulationService] - REST response: {"state":{"on":false,"reachable":true,"mode":"homeautomation","alert":"none"},"type":"On/off light","modelid":"Plug 01","uniqueid":"f87ee55d-e3bf-46d2-8c2b-1d044d70d38f-87","manufacturername":"OSRAM","productname":"On/Off plug","swversion":"V1.04.12","hascolor":false,"name":"Ronni\u0027s Garage Door","config":{"archetype":"classicbulb","function":"functional","direction":"omnidirectional"},"capabilities":{"certified":false,"streaming":{"renderer":false,"proxy":false},"control":{}}}
2020-12-28 15:08:18.238 [DEBUG] [ulation.internal.HueEmulationService] - REST request GET 2fec6024-99f5-458d-be72-c4bc4241e3d5/lights/9
2020-12-28 15:08:18.239 [DEBUG] [ulation.internal.HueEmulationService] - REST response: {"state":{"on":false,"reachable":true,"mode":"homeautomation","alert":"none"},"type":"On/off light","modelid":"Plug 01","uniqueid":"f87ee55d-e3bf-46d2-8c2b-1d044d70d38f-9","manufacturername":"OSRAM","productname":"On/Off plug","swversion":"V1.04.12","hascolor":false,"name":"iBox","config":{"archetype":"classicbulb","function":"functional","direction":"omnidirectional"},"capabilities":{"certified":false,"streaming":{"renderer":false,"proxy":false},"control":{}}}

However, still the devices that do not exists are not added and the devices that do exist cannot be controlled any longer. All Hue Emulated devices currently in Alexa say “Device is unresponsive”

Something else I also just noticed, Alexa does not seem to be discovering my Tasmota devices anymore either. ??? I went ahead and removed all my devices and rediscovered. Only devices added through skills have been discovered at this point. :frowning:

It seems Alexa is now sensitive to the value used in the uniqueid field and that the values generated by the 2.x version of the Hue Emulator are too big.

In paperUI you can try setting the Unique bridge id for the Hue Emulation to something like 48:49:22:9A:9B:5A:E8:B2. Then restart OH and try device discovery again. This should result in more Alexa friendly IDs being generated which might help with getting lights discovered.

Changing the uuid did not work unfortunately.

You might also have to activate pairing again after changing the uuid, but pairing with Alexa might also not be working in 2.x.

The pairing and discovery issue seems to be fixed in OH3, but some users are reporting that devices are still not responding so I suspect there are more fixes needed. It’s working ok for me at the moment with OH3.

Everything was working for me two days ago. Then I went to add another device and nothing is working.

Have you added any new echo devices recently?

What echo devices do you have and what software version are they running?

I have indeed added some new devices recently. A couple of Echo Flexs’ over the past couple of weeks.

Regardless, it is working again. In an effort to get back control of some of my devices I started to setup openHAB Cloud, but I still had the uuid from my old install so I deleted the uuid and secret file and did

#apt-get install --reinstall openhab to create a new one

Then go cloud setup. I then added only one device using the openHAB Cloud config and tested by discovering devices. Annnnd, it then proceeded to go ahead and discover ALL of my HUE Emulated devices. Everything is back up.

Can’t be sure what did it, but if someone else runs into this issue, it could not hurt to do a reinstall. Can’t see why recreating the uuid and/or secret would effect HUE Emulation unless someone could enlighten me.