Hue Emulation - Where to turn next?

I have recently upgraded my OH installation to 2.5.2. This upgrade was performed mainly to restore the Hue Emulation service which failed for me many months ago.

At the onset of the issue I worked to see if I could fix the issue. I checked all setting, used the forum and found that others were having issues and many pointed the finger at Amazon making changes to the service. Later on there were posts of a new Hue Emulation binding that would require you to blow away all of your devices on Amazon and have them rediscovered…some users had luck…others did not…so I decided to wait to try new versions of the binding.

From my readings, most folks have restored their Hue Emulation service and can issue verbal commands to control OH Items.

I have upgraded my install of OH from 2.3 to 2.5.2 with the hope to restore this service.

I have deleted all of my devices from Amazon and had them rediscovered after the upgrade.

I was excited to test…“Alexa turn on the hallway lights” only to be greeted with the familiar response “hallway lights isn’t responding, please check it’s network connection and power supply”

So I have tried to debug…

If I go to:


I get this…

[{“error”:{“address”:“testuser/lights”,“description”:“Not Authorized”,“type”:1}}]

If I go to:

I get this:

[{“error”:{“address”:“testuser/sensors”,“description”:“Not Authorized”,“type”:1}}]

I had “Pairing” turned when I tested both URL’s.

I have my items tagged as follows:

Switch Hallway1 "Hallway Lights" [ "Switchable" ]{ tcp=">[ON:10.x.x.6:3040:'MAP('],>[OFF:10.x.x.6:3040:'MAP(']"}

I read in the documentation that port 1900 UDP needed to be open, I have a rule in my firewall allowing that connection.

Where can I turn next to try and figure out why I can’t get Alexa to see my devices?

All suggestions greatly appreciated.

Squid :squid:

Do you have port 80 redirected to port 8080?

I had a hard time getting it until.

I rebuilt my 2.5 system from scratch. I did this because when i did a test setup with one dummy switch everything worked but my main system emulation had issues.

Here is what i did and have not looked back.

  1. Started from scratch.
    1a. Delete devices one by one from echo
  2. Setup only hue emulation, it worked with a dummy switch.
  3. Added another binding that had devices using hue emulation. Discovered and tested if they worked. They did.
  4. Add back the rest of my things.

I cant explain it (dont care to either), but it worked.
I highly suggest setting up a 2.5 setup on either a vm or another pi drive just to conform you dont have some other issue. All you need is one dummy switch to confirm.

No I do not, from what I could tell some had luck with this…others did not.

If you are using the Hue specific features, it may be worth figuring it out. If you are just using it for Alexa, then I recommend using the skill. I gave up on the Hue emulation binding after it was mangled in 2.4 and I wish I had made the switch sooner. I have not noticed any decrease in performance and the features are MUCH better. I can walk into an room and turn on the light, TV, etc. and you can also now change String Items too!

I’d suggest you try redirecting port 80 as described in the docs. Then log into the Alexa web page and delete all your old devices.

I really don’t want to depend on another cloud service - from my understanding the skill requires the use of .

The ability to use Alexa was a big WAF issue in our home and I would like to restore that capability.

I guess I’ll try the port forward option…but it sure looks like the Hue Emulation is a mess at this point in time. I’m sure David had the best intentions to make it greater than it was…but it seems like he has moved away from OH and we are now left with a binding that seems be in a very fragile state. Wish my JAVA skills were on par with the challenge.


Well, I come back reporting - SUCCESS!!!

I need to thank @MikeJMajor for pushing me to do the port redirection.

Couple of items of note to anyone else who comes along and has these struggles.

  1. I found lots of instructions here in the forums for how to redirect the port in one of the flavors of linux…nothing for the Windows platform…my OH install runs on Windows Server. To redirect the port on Windows, you must open an Administrative command prompt and enter the following command with your IP information
netsh interface portproxy add v4tov4 listenaddress=Your.OH.IP.Address listenport=80 connectaddress=Your.OH.IP.Address connectport=8080

This command will survive reboots…also if you are on a Windows Server platform, make sure you either disable the WWW publishing service or assign it to another port. I then enabled device paring in PaperUI - Configuration - Services - Hue Emulation

  1. Next I went to, clicked on Smart Home and then Devices I removed all of my devices.

  2. When I told Alexa to discover new devices she could not find any of my exposed devices. I happened to notice a blue DISCOVER button on the web page image and I clicked it. Within a few seconds all of my devices were discovered and back in the list.

  3. I held my breath and asked Alexa to turn on the HALLWAY LIGHTS…and like magic…they turned on!

Thanks again to the wonderful support and assistance this community provides…sometimes you just need to be prodded to make things happen.

Squid :squid:


Hello all,

got big problems with the hue emulation. while it works fine with 89 items for several weeks now, after adding some new items, they are not recognized by Alexa. Total number of items is about 100+ now.
There is one problem in the log reported:

[WARN ] [ueemulation.internal.upnp.UpnpServer] - Could not send UPNP response: Network is unreachable (sendto failed)

Echos do not forget the items even after uninstalling hue emulation. updated to 2.5.4 snapshot but did not solve my problem.

Any suggestions?


@cuse I believe you should start a new topic. Make sure to include the pertinent details about versions and such as well as log files if needed.

1 Like

I have done a factory reset with every echo and uninstallad the hue emulation, deleted everything and reinstalled the snapshot version 2.5.4, now it works again, at this time all items are found. Thank you!