HueEmulation and Google Home support

For Domain/api/discover.xml
I get {“lights”:{}}

But google home still wont connect.

As there are more users having pairing issues is there some alternative solution to pair?

I’d your lights is really empty, you may have problems in your items file. Take the examples from the hue emulation openhab docs and paste them into your items file. There should be a lot more between those curly braces after ‘lights’.

When I do the http://openhabianpi/api/discover.xml

I get this

{“lights”:
{“tradfri_0220_mygateway_65537_brightness”:
{“state”:
{“on”:false,
“bri”:-1,
“hue”:0,
“sat”:0,
“xy”:[0.0,0.0],
“ct”:500,
“alert”:“none”,
“effect”:“none”,
“colormode”:“ct”,
“reachable”:true}
,“type”:“Dimmable Light”,“name”:“Brightness”,“modelid”:“LWB004”,
“uniqueid”:“tradfri_0220_mygateway_65537_brightness”,“manufacturername”:“openHAB”,“swversion”:“66009461”,“pointsymbol”:
{“1”:“none”,
“2”:“none”,
“3”:“none”,
“4”:“none”,
“5”:“none”,
“6”:“none”,
“7”:“none”,
“8”:“none”}
},
“tradfri_0220_mygateway_65538_brightness”:
{“state”:
{“on”:false,“bri”:-1,“hue”:0,“sat”:0,“xy”:[0.0,0.0],“ct”:500,“alert”:“none”,“effect”:“none”,“colormode”:“ct”,“reachable”:true},
“type”:“Dimmable Light”,“name”:“Brightness”,“modelid”:“LWB004”,
“uniqueid”:“tradfri_0220_mygateway_65538_brightness”,“manufacturername”:“openHAB”,“swversion”:“66009461”,“pointsymbol”:
{“1”:“none”,
“2”:“none”,
“3”:“none”,
“4”:“none”,
“5”:“none”,
“6”:“none”,
“7”:“none”,
“8”:“none”}
}
}
}

Does this look right for pairing with the Google Home?

I finally also got some similar values @ /api/discover.xml, but GH is still not pairing.

Question: will the heu Emulation be found also with the official philips heu app?

For everyone having issue; mine has been setup and working since the addon’s inception(at least 4 months).
For the last two weeks it just stopped working.

Maybe google updated the firmware or something, I dunno.
Alexa still works; all google home units do not.

Not good for new Owners.

What firmware is your Google Home?

My updated to Firmware version 1.26.93937 two days ago.

how does one get this info off the unit?

https://support.google.com/googlehome/answer/7365257?hl=en

This output looks right. The problem may the new firmware as @milty456 suggested.

I have sent my GH back to Google, because I am not satisfied with the functionality in Germany, yet. Will try again in half a year or so. Cannot try any more stuff for you guys, unfortunately.

I couldn’t find a single app, that work with Port 8080. Never tried it with Port 80, though.

Can’t get the firmware that way…i refuse to update my app so it basically blocks you from getting the firmware.
I need the old app to keep this working.
Fun fact…it magically started responding again last night after two weeks of not working.
Haven’t changed anything.

I know this issue hasn’t come up in a while but I wanted to reiterate the steps here because I have spent hours trying to figure this out. I made a few changes today and even though I had read this multiple times, I completely forgot about it and have run in circle for a few hours.

  1. Stop OH2 service
  2. Delete whichever entry in openhab2/userdata/hueemulation/items corresponds with the tag you removed from your .items file in /conf
  3. Restart OH2 service
  4. Celebrate

Thanks greg and HomeBoss for posting the fix!

I get this error when trying to update the iptable ->

modprobe: ERROR: …/libkmod/libkmod.c:557 kmod_search_moddep() could not open moddep file ‘/lib/modules/4.4.50-v7+/modules.dep.bin’
iptables v1.4.21: can’t initialize iptables table `nat’: Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.

os -> openHABian

Any help appreciated

Hi, I had HueEmulator (v2.00 from Digitaldan) up and running with my Google Home. Sudenly this stopped working.
Now I have reinstalled everything, but Google home app can’t find my google home, it redirect to account.meethue.com
Open 192.x.x.x\api/description.xml displays the xml.

Please help!

no one?

I think its now impossible to use the Hue Emulation with Google Home. I removed it on mine after months of perfect working, and when i tried to set it up again i also got redirected to the meethue.com site. I tried old versions of the GHome app which worked for some others, but not for me.

So if its working for anyone - dont remove it!

@hypernative - Your only option is to wait for the official Openhab integration discussed here:

1 Like

Can confirm. We are no longer being redirected to http://hue-adapter.appspot.com

I installed Fiddler, a network traffic manipulation tool, to my PC and proxied all traffic from my phone through the PC.

I’ve managed to redirect the Google Home Philips Hue pairing URL to http://hue-adapter.appspot.com/ successfully.

Unfortunately, the page just says the same thing as when opening it here in the browser: Please open this site from the Google Home app or similar.

There must be something set in the User-Agent or a Header but I don’t know which. If anyone has the old Google Home app available, please sniff the http request to the hue-adapter page.

FFS I just deleted my devices from Google Home so I could relink them as it had duplicates in there and am getting redirected to the dreaded Philips website, and now I come in here and read that it’s toast… Great. Well done Google, snatching defeat from the jaws of victory again. I’ll see if I can get an older version of Home from apkmirror.

So far I’ve been back to versions of the Home app from early October 2017 but all redirect to the Philips website. I suspect it might be a server-side redirection.