HueEmulation and Google Home support

In case anyone needs to know, that did the trick. You can’t run ha-bridge at the same time as hue emulation since they’re basically trying to do the same thing and occupying the same ports. Disabling ha-bridge and running the iptables command above resolved all the issues and it’s all working great now!


OK so it’s almost perfect, why is the Home finding everything twice?

Solved this - just reboot the Google Home

I’m still having the issue where everything looks good from the server end, just not seeing the google home or the android phone that I am setting it up with send ANY packets, with trace logging enabled in the emulator.

Is there anything that can block the application from sending that information out? I can use other programs like BubbleUpnp and they seem to work fine… just not seeing anything when the hue app from google home tries to connect.

Any ideas? Can someone show me log files from when they click “pair” in the app with trace logging enabled for the emulator? Is there anything I can do to try and debug this, or help someone debug this?

Home & Hue emulation is generally working well for me since a couple of weeks.
But today I added two lights to openhab: one simple switch and one Fibaro Dimmer 2.

I have linked items and can control the dimmer and switch just fine from the openhab UI.

Naturally, I then want Google Home to be able to control them so I go into the file org.eclipse.smarthome.core.items.Item.json and adding tag “Lighting” and a label for the switch. It then works fine with Google Home.

But I can not find the dimmer anywhere in this file. What am I missing?

I had similar issues, I found that my firewall was blocking the UPNP requests. Try to use an UPNP browser app on your phone/tablet and see if you see the Hue Emulator. I even see it in the windows 10 network browser now.

I currently use the “paper ui” hue emulation for amazon echo.
If i remove the paper ui version and drop this jar in…i have a few questions"

Will echo be affected?
If i want to revert back, what steps do i need to take?(remove jar, restart openhab, reinstall paper ui emulation)?



Hue emulation works fine for me. It is just that I cannot find the dimmer item in any file :slight_smile:

When i tell GHome to turn on the dining room light…it says turning on two lights and turns both of these on:

Switch DiningRoomLightEchoSwitch “The Dining Room Light” [ “Switchable” ]
Switch EchoLivingRoomSwitch “The Living Room Light” [ “Switchable” ]

You have to configure the rooms in the Google Home app on your phone. The rooms are not defined by the labels.


If you look at the screenshot i posted in there, i think i already did that, no?



Ah sorry, I misunderstood where the screenshot was from.

If you swipe to “Rooms” and click on “Dining Room”. Do you then have both the Dining Room Light and the Living Room Light there?

And I found the error why my dimmers did not show up in org.eclipse.smarthome.core.items.Item.json:
Items will not be created for ‘real’ if you use Simple Mode, so I will simply create the links manually from now on.

No problem.

Each room only has 1 item…respectively as it should.

So i tried deleting the files in the /var/…openhab/…folder, renaming them in my items file and restarting openhab.
I unlinked and relinked hue in the ghome app.

I now have triplicate items in the app.
What is going on here?

Every time i wipe those specific files mentioned above and redo it, it adds another entire new set on the app when i unlink and relink hue…I no have 112 when i should have like 25.

Can anyone tell me how to reset all of this cleanly?

Ok, so every time you clear this, you need to reboot ALL your GHome units…in my case 3.
All triplicate items have been removed from my App

Having another issue here;

Specifically with Amazon echo.
Prior to this it used to work fine.
After introducing this binding, it is causing issues.

I have an item:
Switch EchoBedRoomLight “The Bedroom Light” [ “Switchable” ]

I used to say Alexa, turn on the bedroom light, it worked fine.
After this binding, it started replying, “that command doesn’t work on device bedroom”

So i changed the item to:
Switch EchoBedRoomLight “Bedroom Lamp” [ “Switchable” ]

It still replies with that error.

Any idea what is happening here?

I also noticed i have to discover twice now; the first time alexa finds my ecobee and sensors; if i discover again, it finds the “hue lights” off of this binding.

I have no groups in alexa:

And the lights shows up in alexa:



Does anyone have the TargetTemperature working? I’m using @digitaldan’s latest build.

The [“Switchable”] and [“Lighting”] tags get instantly added to my discovery.xml file, but I can’t get a [“TargetTemperature”] to show up in the discovery.xml file, so it won’t be recognized by Google Home:

Number TVSleepTimer "TV Sleep Set Point" [ "TargetTemperature" ]

Has anyone else run into this issue?

One more question… is it possible to launch Pandora from OpenHAB? I know that I can use my voice to tell Google Home that will turn Pandora on, but can I programmatically tell Google Home to turn on Pandora through OpenHAB?

Like when I come home for the day and I open the door, it’d be nice for my house to:

  1. Turn on my speakers
  2. Set the speaker input to Chromecast Audio
  3. Play Pandora to whatever pre-defined channel I specify

I am now having the issue some have experienced…everything works, then degenerates into not working.
I am unable to repair it.
I’ve tried removing the files in the hueemulation folder, removing the items and readding into the google home app, rebooting openhab, and rebooting the google home units…nothing works.
I just get a response “sorry i am unable to process your request”

I have a switch that sets my AC on 68 for 2 hours:
Switch Hold682Hours “Two Hour Hold” [ “Switchable” ]
it fires off a rule that sends an action to my ecobee.

It was working this morning, then all of a sudden quit.

As stated, resetting everything above multiple times, does not correct it.