HueEmulation and Google Home support

I check the discovery.xml and it’s in there:

“type”:“Dimmable light”,“name”:“Two Hour Hold”,“modelid”:“LWB004”,“manufacturername”:“Philips”,“swversion”:“1.15.0_r18729”,“productid”:“Philips-LWB014-1-A19DLv3”,“pointsymbol”:{“1”:“none”,“2”:“none”,“3”:“none”,“4”:“none”,“5”:“none”,“6”:“none”,“7”:“none”,“8”:“none”}},“42”:{“state”:{“on”:false,“bri”:0,“hue”:0,“sat”:0,“xy”:[0.0,0.0],“ct”:500,“alert”:“none”,“effect”:“none”,“colormode”:“ct”,“reachable”:true},

Maybe google did an update? Does anyone know if there is a way to debug things or check code levels of a google home? Basically if i nickname Two Hour Hold in the GHome app to “Too Hour Hold” it works again…did they push an update that restricts naming things with numbers.

It seems that both google and amazons units are bad at deciphering numbers and room names that might also be groups…which is nuts because if you have a bunch of things, you’d want to name them properly so you can easily turn things on and off. ie Bedroom Light Kitchen Light 1 Kitchen Light 2

Those two things “room types” and “numbers” are the two Achilles heels of both of these units.
You can get around it by groups or nicknames, but that means every time you want to purge and re discover, you need to redo all of that again on each ecosystem.

Hello All,

I am trying to get this to work on MacOS, but I am having some trouble with the port redirect. I have found this command and it seems to work, except it kills connections on port 8080.

echo “rdr pass inet proto tcp from any to port 80 -> port 8080” | sudo pfctl -ef -

Once I run this Google Home works great, but I can’t load paper etc, and other things break.

Anyone know what I need to do to keep both running?

Which is the latest Hue Emulation binding with Google Home support?
I have a manually downloaded jar that works but quite old now.
I tried the OH2 snapshot but I get no lights in the description.xml file then and of course GH can the not control anything (“all lights seems to be offline”).

Same question here.

I’m still using the binding jar attached in this thread from @staalebk

@digitaldan - Hi Dan - im sure you are busy, but could you push the updates into the snapshot builds? I think this would reduce a lot of the headaches people trying to use this binding are having.

Yeah, that’s the one I am using also. Would be great to get it into the snapshot.

So I installed the jar file, configure in PaperUI, setup a device label, setup the port forwarding, and can see the discovery on the correct port. When I try to setup Google Assistant on my phone to connect I get a “couldn’t find hue bridge error” is that because this isn’t working with Assistant, because I need to punch a hole through my firewall for Hue to get access (not thrilled about doing that) or am I not thinking of something else that might be causing the issue?

Edit: I also tried installing the Hue app. It sees the bridge but crashes on trying to connect to it.

Are you sure you are getting the “correct” discovery file? Some other people have had problems with hitting another hue emulator.

I would think the Hue app would not work, as the xml is just a minimal thing just to fool google home. Google home would need to be able to contact your hue emulator on your internal interface. No need for adding a hole to your external IP.

Here is what I’m getting back:

{"lights":{"1":{"state":{"on":false,"bri":0,"hue":0,"sat":0,"xy":[0.0,0.0],"ct":500,"alert":"none","effect":"none","colormode":"ct","reachable":true},"type":"Dimmable light","name":"Dining Room Lights","modelid":"LWB004","manufacturername":"Philips","swversion":"1.15.0_r18729","productid":"Philips-LWB014-1-A19DLv3","pointsymbol":{"1":"none","2":"none","3":"none","4":"none","5":"none","6":"none","7":"none","8":"none"}}}}

I suspect it’s that the emulator only works with Google Home and not Assistant. Especially given your 2nd statement and the fact I can’t connect with the App. It looks like Assistant goes through Hue’s cloud interface which w/o the connection there working won’t allow Assistant to work?

I am having the same problem. Could you sort it out?

No, I suspect it’s the Google Home vs. Google Assistant issue. When I get time I was going to try the HABridge approach to see if that might work

HAbridge works for me for items on my Vera but does not expose other devices in OH2 (insteon,zwave). this is why i am sticking with the OH2 emulator.

Are you using Google Home or Google Assistant?

Focusing on Home for now. right now on my fresh install of Ubuntu and OH2 with the downloaded JAR above I still cant get my Home to see it. i have tried the iptables 80-8080 reroute as well and i DO see devices in the browser when i hit :80/apt/devices.xml

im missing something

Unfortunately I’m trying to get assistant to work which I strongly suspect isn’t compatible so at the same point of seeing them in the browser but not able to connect. Sorry that I can’t be of more help.

Thanks for the reply Rgerrans,

I am taking the Google Home-> IFTT -> OpenHAB route. But if you succeed in
HABridge please let me know. I would like to try that.

i have rebuilt my OH2 server clean from scratch. I have iptables mapping port 80 to 8080 and I can browse and see lights on the discovery.xml.

i still cant see them in the google home OR google assistant app.

any ideas?

Are able to log the net traffic to/from port 80 using wireshark ?
Maybe that analyzing the communication a bug could be discovered

I dont see traffic from my cell to the OH server. i CAN open a browser on that same cell and hit port 80 which redirects me to the OH2 Page