HueEmulation and Google Home support

I think someone (google) may have updated something because I deleted my previously linked hue account from google home and it will only find my hue bridge that is configured with the hue account. I don’t see the device even poll the openhab2 server.

I found this over at the HA-Bridge support site and it may explain some thing…

Q: Why doesn’t Google Home find my ha-bridge and goes to the website?

A: Google Home now seems to not support local connection to Philips Hue Hubs and requires that it connect to Since the ha-bridge only emulates the local APi, and is not associated with Philips, this method will not work. If you have an older Google Home application, this may still work. YMMV.


Using this APK should restore the local functionality ( found on the HA-Bridge site ) using a older device or android emulator

and install version 1.19.29.

1 Like

Are we mounting some sort of petition or campaign to get them to change it back :slight_smile:

Let the masses speak out…force their hand :slight_smile:

I’d been running a nightly SNAPSHOT build from mid-January on my openhabian install, and decided to do a clean install of the current released version.

I hit the above problem where Google Home didn’t see my hue emulator at all. Using the old Google Home APK on an Android device worked fine for me and things are up and running again.

I just tried this and like many others I ran into trouble.
IP forwarding is enabled. i can see api/discovery.xml on both 80 and 8080 from all computers on network
In the xml is several devices registered.
I tried old APK and new APK but they both just sits there “press the link button to pair”.
Both tries the site:
But in the end it says “couldnt find hue bridge”.

Anyone else with some input on what I can try or maybe another binding?

FYI, I tried using HueEmulation for a bit and switched back to IFTTT: Simple way to use Google Home with IFTTT and myopenHAB. I found it to be more reliable and easier to create complex commands such as “OK Google, Turn on the kitchen table and ceiling lights”. As for speed it seems to be about the same speed since commands need to go to Google to be processed in both cases.

1 Like

Try some of the suggestions over at HA forum.

( I think both are also…“try old apk” )

Hopefully @MARZIMA will have something native and infinitely better for us with this work - no pressure Mehmet :wink: :

1 Like


yeah! Thanks. I was busy this week and already managed to setup the Google example and make it run on Cloud side. Iam going to implement futher and make a WIP PR soon. Due to Ramadan, I got sometimes timing problems am :slight_smile:
I keep you updated. Later I will need help with testers of the Action…Going to notify.


Thank for your work. I’m available for testing. Feel free to contact me.

Next Week i am going to buy an GOogle Home for me aswell and then i am also interessted to test the integration:slight_smile:

Check out the news here: Google Home Integration.
It works pretty well in my tests, but I am clearly also impatiently waiting for @MARZIMA’s Google Home Action :slight_smile:

1 Like

Hello everyone,

I am the proud owner of google home since yesterday. GH now sees my devices over the hueeumu. Unfortunately I can not dimm the devices. I use Zwave dimmer from Fibaro. Alexa had no problem before. The devices are tagged with [“Lighting”]. I use the jar of @staalebk. The on and off function works via GH.
Where is my mistake and where should I look?

1 Like

What did you do so Google Home Pairs with OpenHAB Hue Emulation?

I’m use hueemulation. I just got it. I have the item file (C:\openhab\userdata\hueemulation) renamed to “item_old”, rebooted openhab. A new item file was created. After that, I’m stopped openhab deleted the new item file and rename the old (item_old) again in “item”. Now everything works.


I used iptables on my openhabian to route port 80 to port 8080. This way, I neither need to run openhab as root, nor do I have to install a reverse proxy:

iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to 8080

It does not seem to have any (negative) side effects. Port 8080 continues to work, of course. Pairing worked instantly within Google Home App.

In which file has this line to be added for getting it to work?

It’s a Linux command. You log in to your system running openhab, become root and run the command.

To have it run on each reboot, you can append the line to /etc/rc.local. Be sure to place it before (over) the “exit 0” line in that file.

1 Like

Now I can access e.g. paperui on both port 8080 and 80, but the the Google Home can still not find the hue-emulation on my RPI.
Do I miss something?

Your not alone it must be something else. I do hope that someone might be able to help us.