iCloud Binding Communication Error

Last time, it was an apple issue…perhaps we have to wait a couple of hours… ;-(

1 Like

Same here since 6 pm


Is this working for you guys?

No, still same error

Yeah I´m having the same issue…

java.util.concurrent.ExecutionException: org.eclipse.jetty.client.HttpResponseException: HTTP protocol violation: Authentication challenge without WWW-Authenticate header

1 Like

same here

Just to be part of the group…same here…

Same for me…

Me to

Yes, same here

I’m really sorry, I currently do not have time to solve this issue but I looked briefly at the error and code and added a remark in: [iCloud] Bridge-Thing generates Communication Error · Issue #13282 · openhab/openhab-addons · GitHub

Good luck and sorry that I can not be of more help.

1 Like

I did not understand what’s exactly the issue, but looks like it’s related Apple issue?

For me it is hard to believe, that it is an Apple issue. Why do I say so …

I have setup an Home Assistant environment to test a few things. Home Assistant provides an integration with pretty much the same functionality as openHAB does. HA uses a different (standard Apple) authentication method. Everything works there.

I must conclude, that the problems we see are OH problems and must probably be solved by the OH contributors and maintainers.


Well, your conclusion is incorrect.

  • Yes, openHAB is using a different approach than other smarthome systems. That in general is no issue.
  • Apple is violating standards with sending incomplete responses upon reqquests.
  • It would be better to change communication to another approach. Feel free to make a contribution.
  • It is not the maintainers job to fix bugs or change bindings.
1 Like

I don’t see any progress here.
There is obviously nobody here who takes care of the binding…
I am just a normal user in this case…sorry!
I will uninstall the binding now…until it runs again in a future version of OpenHAB…

Good luck everybody!

I switched my solution to pyicloud library which is using HA and it is working fine.

How did you do it?

@Trinitus01, you have solved communication errors earlier. Is it possible for you to have a look on the current issue?

I prepared python scrip and using exec binding for run of the script

1 Like

Sorry to ask and to bother. Since I am a “standard”-user I do not have any clue what to do to solve this apple issue.
This was working fine and it was a very useful binding…

Any chance to convince the owner of the binding to fix the issue?