iCloud SSL issue again

Please do so - I would like to avoid the hustle of building my own .jar

Nice catch and KUDOS - had the same suspicion, but not enough coding skills to fix it myself

Ok guys,

i think i have a quick dirty solution that works for my installation (windows)

Now the Things will go online (for another year) :wink:



Congratulations friend, I followed your procedure worked perfectly on linux, just did a different step, edited the .jar file directly with the editor vim linux, now it’s all online, thank you for your cooperation.

I get the following ERROR LOG:

2019-08-08 09:45:41.645 [ERROR] [org.apache.felix.fileinstall        ] - Failed to install artifact: /usr/share/openhab2/addons/org.openhab.binding.icloud-2.5.0-SNAPSHOT.jar
org.osgi.framework.BundleException: The bundle file:/usr/share/openhab2/addons/org.openhab.binding.icloud-2.5.0-SNAPSHOT.jar does not have a META-INF/MANIFEST.MF! Make sure, META-INF and MANIFEST.MF are the first 2 entries in your JAR!
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.installOrUpdateBundle(DirectoryWatcher.java:1005) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.install(DirectoryWatcher.java:963) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.install(DirectoryWatcher.java:884) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:489) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [10:org.apache.felix.fileinstall:3.6.4]

Do you have any ideas?


I solved it by editing the JAR file with 7Zip and replace the certificate lines in the JAR file direct.

Thanks RalphSester,

i was able to get the bindung up and running. There seems to be no error in logs. The discovery delivered all my iCloud devices. I can create items for all my devices channels but there is no data recieved. Battery state etc. show all NaN.

Any idea what went wrong?



after starting openhab cli console and running a bundle:restart <id of iCloudBundle> all information showed up.

Don’t know why.


1 Like

Perfect worked like a charm … i also just edited the Jar with VIM

Hi Q
can i find the installed jar on my machine
or it is mandtory to download ?

same thing here neede to restart the bundle

Also need bundle:restart but now back alive :slight_smile:


I see that a PR to fix this had already been merged so snapshot users should already be fine, I think non snapshot users should be able to update the iCloud binding to the snapshot version, can someone who is not on mobile (on the backseat of a car) provide some steps for this :blush:

How does one update to this snapshot? Just remove the current binding and then drop the snapshot into the addons folder?

correct. Maybe you need to restart the bundle afterewards (openhab console -> bundle:restart

Install M2 version from openHAB console

bundle:uninstall org.openhab.binding.icloud
bundle:install https://openhab.jfrog.io/openhab/online-repo-milestone/2.5/org/openhab/addons/bundles/org.openhab.binding.icloud/2.5.0.M2/org.openhab.binding.icloud-2.5.0.M2.jar

Or uninstall previous one and download jar directly from link and add it to openHAB addons folder

If gson 2.8.5 lib is not installed on your environment, you can install it by following command

bundle:install http://central.maven.org/maven2/com/google/code/gson/gson/2.8.5/gson-2.8.5.jar

The following process should work to upgrade 2.4 to the snapshot version of the binding:

  • uninstall the iCloud binding through PaperUI
  • download the snapshot version of the binding from https://ci.openhab.org/job/openhab-milestone/ into the addons folder
  • open a karaf console and execute the following command: bundle:install http://central.maven.org/maven2/com/google/code/gson/gson/2.8.5/gson-2.8.5.jar
  • restart openhab
  • use bundle:list to check that the gson binding is running; if not start it with bundle:start
  • check that the iCloud binding is running

I triggered a new build so the fix should also be available in the next snapshot build (#1656 if all goes well). The 2.5.0.M2 milestone release should already have this fix. Because the M2 is so new, it actually contains more recent commits than the snapshot (which is rare). :wink:


Hi, I follow all steps you mention and I have this problem. I get this message when I triy to start the icloud binding:

206 │ Active │ 80 │ 2.8.5 │ Gson
207 │ Installed │ 80 │ 2.5.0.M2 │ openHAB Add-ons :: Bundles :: iCloud Binding
openhab> bundle:start 207
Error executing command: Error executing command on bundles:
Error starting bundle 207: Could not resolve module: org.openhab.binding.icloud [207]
Unresolved requirement: Import-Package: com.google.gson.annotations; version="[2.8.0,3.0.0)"

I need some help!

+1 here

I just realized that iCloud binding began to work :smiley:

A few hours ago I had the same error as ramon2k10:

I assume that a restart of openhab2 fixed the problem: