Ikea Tradfri and thrid party CW/WW LED controller

Hi there. A while back I’ve ordered a Chinese Zigbee Light Link CW/WW LED strip controller to interface with my kitchen light (it’s a modern lamp that was using an IR remote controller). I replaced the integrated controller with the one that I received and the controller works just fine with my Tradfri gateway and app. I can control the brightness and the color temperature from the app just fine.

The controller appeared in my openhab paperui inbox just fine with two channels - one for brightness and one for color temperature. But the color temperature channel isn’t working. When I change the color temperature in the Tradfri app, the color temperature slider in paperui changes as well. But changing in the openhab does nothing to the light.

These are my items:

Dimmer Zgoraj_Kuhinja_Light_Temperature "Luč barva" (Zgoraj_Kuhinja) {channel="tradfri:0220:gwa0c9a0d98edb:65557:color_temperature"}
Dimmer Zgoraj_Kuhinja_Light_Brightness "Luč svetlost" (Zgoraj_Kuhinja) {channel="tradfri:0220:gwa0c9a0d98edb:65557:brightness"}

And then my sitemap:

      Slider item=Zgoraj_Kuhinja_Light_Brightness
      Slider item=Zgoraj_Kuhinja_Light_Temperature

This is the controller that I am using:

One thing that I find slightly weird is that the compatibility matrix says it’s only dimmable using Tradfri, but that doesn’t seem true when using it with the tradfri app. Although the tradfri app shows it the same way as my RGB light (I can select colors - like green and red) and I am not sure if white temperature lights should show in that way (and I don’t have any ikea white temperature-only lights to check). But it works.

Any idea how to get it work with Openhab?

Hi @roli

Some days ago, I also received my Gledopto controller. I am using this device with the Zigbee binding instead of the IKEA one. My Gledopto also has two channels, one for colour and one for colortemperature. Unfortunately, I am also not able to use RGB colour, only hue/sat.

Did you manage to fix your problem?

Kind regards,

Hey! I actually did solve my issue just last week. Actually it kind of solved itself. I was using a Philips Hue hub with it and it was constantly giving me issues. So I just randomly tried the Ikea hub again, to see if it is working now… and it was. I’ve been using that light with the Ikea hub for a week now and it’s working just fine. So I am not sure if it was an update on the Ikea side or on the Openhab (I am now using 2.5M3) side.

But seeing how you have an issue with the Zigbee binding I don’t think it relates.

1 Like