Image with local url not working in android app

I am looking into using grafana instead of the built in charts. Things work, but for one annoying thing: when connected to the local network (wifi) the android app doesn’t show the image. Oddly, when disabling wifi and connecting remotely through myopenhab it works. When using the browser on the phone the basic ui works.

I have tried adding an image with a url from the internet. That worked fine.

I have tried adding an image to the html folder and accessing through the openhab page which works.

I also set up a Webview. I couldn’t make that work until I found a setting in grafana about allowing embedding. Now it works, but I don’t like the rendering too much and it doesn’t work remotely.

I am suspecting it has something to do with using the hostname instead of the instead of the ip, since that doesn’t work on the phone, but it is setup using the ip in the app and in the sitemap, so it should should be translated somewhere internally and only for this url.

Does anybody know what could be wrong or how to debug this further?

I am running everything within a virtual server on a NUC and using docker containers.