Import-package requirement fails, .m2 folder does not contain the supposed package. How do i put required files in this folder?

Tags: #<Tag:0x00007f5c94ef2c78>

Good evening everyone,
i am trying to develop my own binding for a big college project.
The project briefly consists in simulating the behaviour of multiple sensors (e.g temperature, humidity, and such) and having them show up in the OpenHab runtime, visualizing and managing their data.
To achieve this communication, both my “simulated sensors” software and the OpenHab binding talk via Json messages through PubNub (a realtime database which has the Publish/Subscribe functions i need)

I am importing PubNub as the OpenHab Doc says on importing external non-OSGi libraries, through a line on both the pom and feature. It builds and compiles (through “maven clean install”) correctly.

However when from the OpenHab console i run “bundles:list” i see my binding is “installed” and not “active” as it should.
A “restart [id]” command yields the following error:

Unresolved requirement: Import-Package: com.pubnub.api

A “resolve [id]” instead simply does not do anything, or yields anything visible.

This is my pom line, as per PubNub official documentation this is the only dependency i need to add [source here]:
(all < and > are not shown because i don’t know how to escape them in this post, sorry if it is confusing)

groupId>com.pubnub</groupId
artifactId>pubnub-gson</artifactId
version>4.31.0</version
scope>provided</scope

This is my feature line:

feature>openhab-runtime-base</feature
feature prerequisite=“true”>wrap</feature
bundle dependency=“true”>wrap:mvn:com.pubnub/pubnub-gson/4.31.0</bundle
bundle start-level=“80” mvn:org.openhab.addons.bundles/org.openhab.binding.safehome_se/${project.version}</bundle

My “.m2” folder has some files under “com/pubnub-gson/4.31.0/” as it should.
There is no “com/pubnub/api” folder, which i suppose the runtime is asking me.
I suppose i should provide “something”, some jar files or whatever, to this folder, but this has always been an automatic process so i do not know what to put in, nor how.

Question:
Is this the correct approach to solve this error, at all? How do i put these files in the .m2 /api folder it is asking me to?

I tried to search both the docs and this community threads before writing this post, but i could not find anything that precisely solves my problem, or simply i don’t understand enough the answers to know if they could apply before trying them out.