InfluxDB filesystem full


I’m using an openhabian installation with influxDB installed. Had an issue with my old SD card but unfortunately don’t have a backup of the influxDB! Have managed to recover the influxdb files and want to copy them over to a fresh openhabian installation into /var/lib/influxdb. However, i keep getting disk full errors. When looking at the filesystem it appears that influxdb filesystem is 100% full.

Is there a way to increase this filesystem size? I assume it was openhabian install that set this filesystem, but i can’t see anywhere i can change it.

Here;s my filesystem:

Filesystem      Size  Used Avail Use% Mounted on
/dev/root        29G  9.1G   19G  33% /
devtmpfs        916M     0  916M   0% /dev
tmpfs           950M     0  950M   0% /dev/shm
tmpfs           380M  2.6M  378M   1% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
/dev/mmcblk0p3   30G   28K   28G   1% /storage
/dev/mmcblk0p1  255M   33M  223M  13% /boot
/dev/zram1      721M   36K  669M   1% /opt/zram/zram1
overlay1        721M   36K  669M   1% /var/lib/openhab/persistence
/dev/zram2      323M  316M     0 100% /opt/zram/zram2
overlay2        323M  316M     0 100% /var/lib/influxdb
/dev/zram3      974M  176M  731M  20% /opt/zram/zram3
overlay3        974M  176M  731M  20% /var/log

The old influxDB database files total to around 1gb

Any help appriciated

You’ll have to disable ZRAM. 1GB is simply too big to fit in RAM and have enough left over to run OH and everything else unless you have like 8 GB of RAM. Zram file systems live in RAM.

However, be aware that this means that all those writes to the DB will not be hitting your SD card meaning that the SD card will wear out much sooner. Make sure you have a tested and good backup and restore regime.

You can disable zram from openhabian-config. You can probably just turn it off for InfluxDB by editing the zram config files in /etc.

Thanks @rlkoshak I’ll remove Influx from ZRAM using the config file and see if that works. I updated /etc/ztab file and commented out the line for influxdb. Thanks for the info, not something i was aware of :+1: