Influxdb not connecting

  • Platform information:
    • Hardware: arm64/4GB/32GB SD Card, 500GB HDD
    • OS: Raspbian
    • Java Runtime Environment: Docker
    • openHAB version: 3.3.0

I am trying to get openhab to use influxdb for persistence, but keep getting this error in logs:

15:23:40.944 [DEBUG] [e.influxdb.InfluxDBPersistenceService] - store ignored, InfluxDB is not yet connected

Influx 1.8 is running in a docker container and this query works from inside the openhab container:

root@bigmac:/openhab# curl -i -XPOST 'http://localhost:3201/write?db=openhab&u=openhab' --data-binary 'cpu_load_short,host=server01,region=us-west value=0.64'
HTTP/1.1 204 No Content
Content-Type: application/json
Request-Id: 8fcb2778-0ce7-11ed-804d-0242ac140002
X-Influxdb-Build: OSS
X-Influxdb-Version: 1.8.10
X-Request-Id: 8fcb2778-0ce7-11ed-804d-0242ac140002
Date: Tue, 26 Jul 2022 13:33:40 GMT

This is my influxdb.cfg:

# The database URL, e.g. or .
# Defaults to:

# The name of the database user, e.g. openhab.
# Defaults to: openhab
# user=<user>

# The password of the database user.
# password=

# The name of the database, e.g. openhab.
# Defaults to: openhab

Influx Logs also show no requests from openhab

set user and password :slight_smile:

1 Like

random values? doc says it’s optional and I have no auth configured. (Influx is running fully local)

at least you are using a user name openhab in your curl command:


Ah, just seen… “defaults to openhab”…

Well… I would recommend to set both user and password…

Oh… stupid me…

You are using openHAB3.3, therefor, you have to set the path through the MainUI…

Well the curl command was working without user too, but I just tried it with random values for user and password and it worked!

Maybe a bug in it then? I just used openhab and openhab for user and password. Influx was never configured in any way, fresh docker setup.

Anyways, thanks it works now!

really? Not sure whether i did that. But why? Sounds pretty annoying if you need to configure that by hand or API requests

No… seems to have changed once more… there was an option to do it via MainUI… but in fact, as I’m searching for, it’s gone…

isn’t it under
Settings => InfluxDB Persistence Service
there you have all parameters to configure

yeah it is there, but I think it is synced with the config files

or it has some hierachy like first read config files and then UI overrides (or other way around, probably makes more sense)

Yes. for whatever reason openHAB didn’t create the influxdb.cfg file when I installed influxdb… maybe some issues with permisions… it’s a test system…