InfluxDB not doing anything

Running openhabian…

2019-05-10 01:19:09.292 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model ‘influx.persist’

2019-05-10 01:19:51.784 [thome.event.ExtensionEvent] - Extension ‘persistence-influxdb’ has been installed.

These are the only two log messages I get


I can curl the influx url, and login via cli to the database

Strategies {
everyMinute : “0 * * * * ?”

Items {
Outlet1 : strategy = everyMinute

Not sure why openhab isn’t logging anything else out…

Does Outlet1 have a state? Is the state changing?

Put the InfluxDB add-on into debug or trace logging to see if it is trying to write out the values. See Log4j2 Sample Config.

Look at the InfluxDB logs to see if it is experiencing any problems on that end.

Did you install influxdb and grafana from the openhabian-config utility?

if so, in my experience that utility creates the users openhab and grafana in influxdb but doens’t grant them permissions.

(from InfluxDB+Grafana persistence and graphing)

It would be helpful to file an issue on the openHABian project if that is the case. See How to file an Issue.

The file has to be named influxdb.persist


It works now…

… I’m gonna go format all my harddrives now …


What was the problem causing the issue?

… both useful for anybody else encountering the same situation, and for me to know whether to follow rlkoshak’s advice of filing an issue on github…

the filename was incorrect, influxdb.persist, not influx.persist

Dear Udo, thanks a mill.

Solved my issue with influx not persisting, after two days of searching…