Innogy binding authorization problem http 500

Seems that innogy did some changes to the configuration and since yesterday openhab can’t authenticate anymore.
2020-06-30 06:53:36.099 [ERROR] [oauth2client.internal.OAuthConnector] - grant type refresh_token to URL failed with HTTP response code 500

Is this only me or are others affected as well?


I have the same problem since Yesterday. But with an different error code.

[ERROR] [oauth2client.internal.OAuthConnector] - grant type refresh_token to URL failed with HTTP response code 429

best regards René

What version are you using?

Acc. to post here :

Just generate new token, using the original link with repaced “api” to “auth”.

Works with mine innogy smarthome.

1 Like

Could you please paste the new link to generate the new token?

Just use the one from innogy central thing Setup in openHAB. Only replace what indicated above.
I do not place it here as I do thing part of it is specific for every central.

Didn’t worked for me. I added the new token, but it’s still offline " Cannot connect to innogy SmartHome service. Please set auth-code! "

Do you use the latest version of the binding? There were API endpoint changes implemented some time ago and I think innogy disabled the old ones.

Welcome Back :slight_smile:

I removed and reinstalled the binding yesterday. But I’m still on OH 2.4 . Maybe it’s time to update again (had many issues with 2.5)


I have changed to openHAB2.5.7 snapshot #159. It already includes the modified binding with the new auth-link.

By the way: the Amazon innogy binding is affected as well as openHAB. There the binding needs to be deactivated and activated again using the new auth-link. This is a mess and i believe that innogy doesn’t take care of the results of such changes.

See also:

I’ve updated to OH 2.5.6 and reinstalled the binding - now it’s working fine :slight_smile:

Hi, same problem on my side. Had response errors “401” or “API calls quota exceeded! maximum admitted 100 per Minute.”
New token generation as described:

Worked for me on 2.5.6 without reinstall.

I updated now to openhab 2.5.7 , and after that I needed to readd the Authorization Code, but after it stays at “initialization” …
I removed the bridge, and now discovery won’t find it anymore … any ideas?

After removing the add-on, delete temp & cache & reinstall the add-on its working again

I’ve got the same issue after 2.5.7 update, but your solution did not work.
I keep getting the same Warning in Log

2020-08-02 10:27:14.526 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception:
java.lang.NullPointerException: null
at org.openhab.binding.innogysmarthome.internal.client.entity.device.Device.setReachable( ~[?:?]
at org.openhab.binding.innogysmarthome.internal.client.entity.device.Device.setMessageList( ~[?:?]
at org.openhab.binding.innogysmarthome.internal.client.InnogyClient.getFullDevices( ~[?:?]
at org.openhab.binding.innogysmarthome.internal.manager.DeviceStructureManager.refreshDevices( ~[?:?]
at org.openhab.binding.innogysmarthome.internal.handler.InnogyBridgeHandler.startClient( ~[?:?]
at java.util.concurrent.Executors$ ~[?:1.8.0_262]
at java.util.concurrent.FutureTask.runAndReset( ~[?:1.8.0_262]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301( ~[?:1.8.0_262]
at java.util.concurrent.ScheduledThreadPoolExecutor$ ~[?:1.8.0_262]
at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:1.8.0_262]
at java.util.concurrent.ThreadPoolExecutor$ [?:1.8.0_262]
at [?:1.8.0_262]

Did you try restarting (not rebooting) OH a few times? Also if you have openhabian config tool try selecting the option to have all items load before any rules.

After few days another trial to get new authorization key for the binding. And the bridge is OnLine.
Nothing else required.

1 Like

I got a similar problem.
When I enter an auth-code I need first of all more then one attempt to store the auth-code.
After a few attempts the code is stored, but now the error-message says “Invalid authcode. Please generate a new one!”
Openhab is running on 2.5.7 and the Innogy-Binding is also the latest version.
For generating the auth-code I’m using the link from the openhab documentation:

I got this problem since some weeks and I regenerated a view times the auth-code.

Does any one got an idea how to solve this?

Thank you for the help!