Innogy SmartHome binding now part of openHAB project

Hi all,

good news: my innogy SmartHome binding was accepted today and will from now on be officially part of openHAB. YEAH!!!

What you should know:

  1. Official innogy SmartHome binding documentation <- read first, ask later!
  2. You will find the latest version of the binding in the snapshots.
  3. Or download the jar (version from 02.04.2018) from my Homepage.

The binding in OH distro already includes the new redirect URLs for the auth-code generation, that are currently NOT YET ACTIVE! I expect innogy to activate them in the next couple of days. So please use the temporary binding version and the temporary binding version depending on your brand:

And now: HAVE FUN with the binding!


:slight_smile: congratz and tnx for the binding once again…

1 Like

Congratulations! I already used successfully the beta version. Really great work! Thank you very much!

1 Like

As there is still a problem with the redirect URLs, I edited my first post and linked to a temporary binding jar with the working URLs. Please use that, if you start using the innogy binding and have to create a new authcode.

I’m a very grateful user of the temporary binding for quite a while now. Should I just remove the jar-file, add the official binding and configure it via Paperui? I assume I can still use the old item-file or will the channels change.

Thank you very much! Great work!

1 Like

Thank you very much! Great work!

But since Openhab 2.3.0 my Button Count don’t work anymore. Any Idea?


Did you use the same and latest innogy binding before with OH2.2 or did the OH update install a newer binding version as well?

Which device exactly do you use and do you see the channel with the button count still in PaperUI? Maybe removing and adding the device helps.

Hi Oliver,
thx for the fast answer!
Bevor i updated Openhab from 2.2.0 to 2.3.0 i used “org.openhab.binding.innogysmarthome-2.2.0-SNAPSHOT-171110”

The problem is withs this two types of switches:
Wall mounted Smart Controller (WSC2)
In wall Smart Controller (ISC2)

In paper Ui everything is fine and “ONLINE”
When i check it on Habpanel i only get “NULL”


The devices still have the button1_count and button2_count channels inside, but there were probably some changes in the channel configuration. This may lead to some problems with older things. So please try to delete your WSC2 thing in PaperUI and add it again via Inbox/Search. It should not change the ID, so that everything works like before, but hopefully the channels are fine again.

Hi Oliver,

It Looks like that channel endings have changed from “key1_count” to “button1” and so on. I have deleted the Switches from the Things in Paper UI and added it new via Inbox. Buit now i have the Problem that i can not add channel for button press. The battery is automaticly linked but when i try to choose an item for Buttons there are no items.

Hi, sorry for the late reply.

I tried it out and it works for me with a WSC2 - in PaperUI as well as via text configuration files.

In PaperUI simply create a new Number item and link the button1_count channel. Be aware, that the count-channels are advanced channels and only shown, if you click “show more” on the right side…

Maybe you tried to add the button trigger channels. Those are not linkable to an item, but can be used in rules to trigger those.

Hi all,

I would like to send a command to my thermostat with value 0 for off (rule). But i don’t know the correct synthax. Could you help me?

Number Woh_Soll “Wohnzimmer Soll [%.1f °C]” {channel="… :set_temperature"}

I have used: sendCommand(Item, 0) or 0 as Number…

Thanks in advance

Hi Johann,

the right command should be:

sendCommand(Woh_Soll, 6.0)

The innogy thermostats use 6°C as minimal temperature, which equals off.

Thank you, but unfortunately it doesn’t work.

This ist my whole Code

rule “Thermo Woh”
Item Woh_Soll_1 changed to ON //this is Switch for sitemap

sendCommand (Woh_Soll, 6.0)

Woh_Soll_1 is only a virtual switch to trigger the rule?
And do you have Woh_Soll in your Sitemap to manually select the temperature? Does selecting the temperature via BasicUI work?

Yes, Woh_Soll_1 is a virtual switch to trigger the rule.

When I use Woh_Soll in the sitemap (Setpoint with mapping 6-26), it works.

Ok, i have just found my mistake, Woh_Soll_1 is as Number define, It’s so stupid.:triumph:

1 Like

Hi, reinstall of Openhab fixes the Problem and everything is working fine again. :slight_smile: