Inotify error


I’m running openhab-online-2.0.0-SNAPSHOT, downloaded a few weeks ago.

OpenHAB is not picking up changes in the config files (items, sitemap, …)
I noticed this error in the logfiles: "User limit of inotify watches reached"
I think these are related.

Any idea how to fix this?


Is OH the only thing running on this machine? If not do the other services use a lot of files?

See the answer at the following link for how to see what processes are using inotify, how many they are using, and how to increase the maximum number.

In the meantime, a reboot of the machine should clear them up but probably only temporarily.

There is more then OH running on the machine.
I don’t see a link in your message but I tried this command:
for foo in /proc//fd/; do readlink -f $foo; done |grep inotify |cut -d/ -f3 |xargs -I ‘{}’ – ps --no-headers -o ‘%p %U %c’ -p ‘{}’ |uniq -c |sort -nr
Only a few processes with each a few open files were listed.

I rebooted my server and at least OH is picking up the changes in the config files like it should.



That was the post I found earlier.
A reboot fixed it for now.