Install issues - cannot access UI or complete install - receiving Could not start the servlet context for context path [] error - Please assist

  • Platform information:
    • Hardware: Intel(R) Core™ i7-4770 CPU @ 3.40GHz 3.40 GHz, 12.0 GB RAM, 64-bit operating system, x64-based processor
    • OS: Windows 10 Home, Version 21H1, OS Build 19043.1645, Windows Feature Experience Pack 120.2212.4170.0
    • Java Runtime Environment: openjdk version “” 2022-02-08 LTS
      OpenJDK Runtime Environment Zulu11.54+25-CA (build
      OpenJDK 64-Bit Server VM Zulu11.54+25-CA (build, mixed mode)
    • openHAB version: openhab-3.3.0-SNAPSHOT
  • Issue of the topic: Cannot complete setup or access UI; when I enter log:tail I receive various fail notifications

Have followed the Windows installation instructions and searched the site as thoroughly as possible for solution to this issue. For additional information, in order to get results for java -version, I had to change the command prompt to the bin folder for Zulu. When entering from the traditional command prompt I receive this error:

‘java’ is not recognized as an internal or external command,
operable program or batch file.

I have created JAVA_HOME in system variables and have set PATH to C:\WINDOWS\system32. I have also deleted all previous versions of Java. I also have tried removing and reinstalling Zulu and OpenHab and have tried stable and snapshot versions.

The initial error is “Could not start the servlet context for context path []” (error is repeated several times in log)

Any assistance would be greatly appreciated!!!


Full log

OpenHab log.txt (565.3 KB)

Did you follow this instruction: Azul Platform Core ?
JAVA_HOME needs to point to a directory which contains the bin directory.
PATH also needs to include the path to the bin directory ( including bin ).

Did you delete something from the PATH system variable ? Looks like a clean system …?

Appreciate the assistance.

Yes, I followed the .msi instructions. I actually didn’t have a PATH system variable previously; I created one with the "C:\WINDOWS\system32 value after searching online. I also had never gone in to Environmental Variables prior to this attempted install so I don’t know how/why it wouldn’t have been there.

I added C:\Program Files\Zulu\bin to PATH and I can now get the java version from any command prompt. However am still getting “Could not start the servlet context for context path []” error. Also still cannot access UI.

Any additional assistance will be appreciated!

I would try the following:
a) temp. disable any installed Virus engine or Firewall and test again
if that does not help
b) see this post in the related thread Fix for Jetty error when running on host with many cores - #13 by hakan
Then try again. Delete the content of OpenHab log.txt before restarting. In case of errors still happen re-upload Openhab log.txt with new entries.
The log files shows that the service was started on port 8080 but you are not able to connect ? Do you get a timeout or an error message ?

Tried disabling firewall and Virus - no effect.
Did not see in services/runtime.cfg the parameters listed, but inserted them as end text - no effect. Is there a different place to put these values or where these values live for Windows?

Message I receive is:

This site can’t be reached

localhost took too long to respond.

Same message when I try to connect on 8080 and 8443

Any ideas?

OH_log_04-24-2022.txt (565.2 KB)