Install KM200 Binding fail

Tags: #<Tag:0x00007f2fbd768768>

Hello to everybody,

ive bin new to work with openhab

i am trying to install the km200 binding but i became this errormessage.

2019-02-21 10:33:07.550 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-km200, openhab-ui-basic, openhab-binding-openweathermap, openhab-ui-habpanel, openhab-binding-knx, openhab-ui-paper’: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-binding-km200; type=karaf.feature; version="[2.4.0,2.4.0]"; filter:="(&(osgi.identity=openhab-binding-km200)(type=karaf.feature)(version>=2.4.0)(version<=2.4.0))" [caused by: Unable to resolve openhab-binding-km200/2.4.0: missing requirement [openhab-binding-km200/2.4.0] osgi.identity; osgi.identity=org.openhab.binding.km200; type=osgi.bundle; version="[2.4.0,2.4.0]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.binding.km200/2.4.0: missing requirement [org.openhab.binding.km200/2.4.0] osgi.wiring.package; filter:="(osgi.wiring.package=org.apache.commons.httpclient)"]]

is here anybody ther can help me ? i don’t have found a solution in the internet

  • Platform information:
    • Hardware: Raspi
    • OS:
    • Java Runtime Environment:
    • openHAB version: 2.4.0

thx
Björn

Hi Björn,

After moving to OpenHab 2.5.0 Milestone 3 I have the same issue. Do you have solution for this issue?