Install openHABian and connect to WiFi - Documentation link does not work

  • Platform information: Raspberry 4
    • Hardware: Raspberry 4
    • OS: _openHABian from zip file openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz
    • Java Runtime Environment: In the package. not sure I can choose?
    • openHAB version: See OS above
  • Issue of the topic:
    Under the installation guide Raspberry Pi (Prepackaged SD Card Image), Setup, 3rd bullet down is a link to (WiFi also supported it does not work.

Trying to connect to the OH through a wired ethernet via the back of the router: both my computer and the raspberry on on the wired ports of the computer and I can see the IP addresses but none of them connect. Thought I try the WiFi connection but could not find documentation to configure the WiFi on the Raspberry.

  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

You mean something like this documentation?

Open your eyes please. It’s in the same document, just some paragraphs down.

1 Like

How are you trying to connect? Ssh or other method?

1 Like

The link worked this time. I intended to connect Ssh method but decided to re-flash.

Formatted the card using “SD card formatter” with no volume label. Format was a success .
Re loaded Etcher, Selected openhavian, then my 32Gb SD card, and hit flash. It decompressed, then started to write but failed.
Error was: Attention, something went wrong. If the is a compressed image, please check that the archive is not corrupted.
Cannot find Module

Any ideas?


Let etcher do all the work. It will format and write.

Possibly try another sd card or different card reader.

Last year Raspberry Pi specifically said to use SD Card Formatter to format the card. Apparently they now use their own tool.

When I started with the Pi that advice helped people revive cards they thought were bad.

It worked!!!

I have omitted the format step, that I use as a best practice for SD cards, and was not aware that etcher does the format first then flash. It does not indicate format in the etcher window.

Suggest that Danny’s comment be added to the documentation: Let etcher do all the work. It will format and write.

How do i submit this recommendation?



You are free to change it yourself :wink: Look at the bottom of the page.


Please follow the community rules and open a new thread.

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

Hello I ran into an similar issue for a wifi only installation

I modified the openhabian-config before boot to add my ssid & passphrase however it didn’t work. The installation script kept clearing the ssid and passphrase no matter where I set it. Here is what worked:

sudo systemctl stop comitup
sudo systemctl disable comitup
sudo systemctl start networkmanager sudo nmtui

select network with nmtui

check that it works with: ping

If it works

sudo systemctl enable NetworkManager

so it works on boot

Once the install script has fully completed I reenabled comitup in order for the web interface to work

I undid my changes just to be sure

sudo systemctl disable Network Manager
sudo systemctl stop Network Manager

I also set the wifi ssid and passphrase in /etc/openhabian-config after the setup fully completed

sudo systemctl enable comitup
sudo systemctl  start comitup

This is a workaround for wifi only installation :slight_smile: