Install openHABian on ARMbian gives error

I try to install openhabian, according to the documentation, on an Banana Pro with ARMBian and receive an error.

bpro@bananapipro:~$ sudo git clone /opt/openhabian
Cloning into '/opt/openhabian'...
remote: Enumerating objects: 2099, done.
remote: Total 2099 (delta 0), reused 0 (delta 0), pack-reused 2099
Receiving objects: 100% (2099/2099), 1.16 MiB | 1.57 MiB/s, done.
Resolving deltas: 100% (1374/1374), done.

root@bananapipro:/opt/openhabian# sudo openhabian-config
2019-05-20_09:47:56_UTC [openHABian] Checking for root privileges... OK
/usr/local/bin/openhabian-config: line 54: /usr/local/bin/functions/*.bash: No such file or directory
/usr/local/bin/openhabian-config: line 83: whiptail_check: command not found
/usr/local/bin/openhabian-config: line 84: load_create_config: command not found
/usr/local/bin/openhabian-config: line 85: openhabian_hotfix: command not found
/usr/local/bin/openhabian-config: line 86: ua-netinst_check: command not found
/usr/local/bin/openhabian-config: line 87: openhabian_console_check: command not found
/usr/local/bin/openhabian-config: line 88: openhabian_update_check: command not found
/usr/local/bin/openhabian-config: line 89: show_main_menu: command not found
/usr/local/bin/openhabian-config: line 92: system_check_default_password: command not found
2019-05-20_09:47:56_UTC [openHABian] We hope you got what you came for! See you again soon ;)

Does anyone has an idea what /usr/local/bin/functions/*.bash: No such file or directory would be the cause of this error?

openHABian is not supported on/tested with ARMbian which means it may work or not as-is.
The openhabian-config script determines the directory it is in in order to set $BASEDIR .
Either you installed it such that it is not a link to /opt/openhabian/…, or ARMbian works different.

Thanks @mstormi for you reaction.
I am aware that openHABian is primarily supported on Raspberry Pi and PINE 64.
(and I do run it on Raspberry Pi 2/ssd for a long time now.) But i have this BPro lying around which has a real e-sata interface, so i thought i’l give it a try. openhab has been running on this device, but not in the openhabian version.

Coming back to the openHABian documentation page, it has this paragraphe:

Other Linux Systems (add openHABian just like any other software)

And i followed these instructions by the word. So the Github is downloaded to /opt/openhabian.
And i did start the command sudo openhabian-config both from the user home directory as well from /opt/openhabian directory…

Hope there are some other suggestions…

Check if openhabian-config is a link to /opt/openhabian/ and if no turn it into one.
Or you could edit the script at around the line it spits. But you’re on your own from here on.

Only help I can offer is the following: I run openhabian successfully under Armbian on Orange Pi. No clue what’s wrong with your installation Banana Pi, but if you want to compare directories and permissions, tell me.

It was quite awhile back but I successfully installed openHABian on an Armbian running on a Banana Pi Zero.

It might be worth mentioning that the BananaPis are not officially supported by Armbian. All the Armbians that run on BananaPis are hacked together by the community so it’s likely that there is some weirdness.

My BananaPi is offline now so I can’t access it remotely to see what is supposed to be in that directory or whether it exists in my setup.

Thank you all for your input.
I redid the install once more, but got the same result…
BTW, dispite the old BPro platform and not officially supported anymore by ARMBian, the ARMBian version available is reasonable current (see first post).
The nice thing about the BPro is its on board sata interface, which is in my opinion, a much better solution then the USB-sata solution on a RPi2/3+ (when you use a ssd drive).

I installed openHAB on it using the general Linux description and not openHABian, as i did in the past, which works fine. It’s a pitty though i can not use openHABian, which i came to apreciated more an more… And i have to get aquainted with the different directories used…
Kind regards,

OH does not require much I/O performance, so I don’t see the benefit in this.

Made an installation on a bananapi M1 with Armbian 5.73.
Ive used a snap installation who works.
try this :

$ sudo apt install snapd
$ sudo snap find openhab
$ sudo snap install openhab-ondra