Installation error Raspberry Pi

Hello Everyone,

I’m trying to install OpenHab on a Rasberry Pi 3B+. It worked before without any problems.

Now when trying to do a clean fresh install I get this error:

“[sudo] password for openhabian:
2019-07-10_01:21:38_BST [openHABian] Starting the openHABian initial setup.
2019-07-10_01:21:38_BST [openHABian] Storing configuration… OK
2019-07-10_01:21:40_BST [openHABian] Starting webserver with installation log… OK
2019-07-10_01:21:46_BST [openHABian] Changing default username and password… O K
2019-07-10_01:21:48_BST [openHABian] Setting up Ethernet connection… OK
2019-07-10_01:21:48_BST [openHABian] Ensuring network connectivity… OK
2019-07-10_01:21:48_BST [openHABian] Waiting for dpkg/apt to get ready… OK
2019-10-24_09:15:15_BST [openHABian] Updating repositories and upgrading install ed packages… OK
2019-10-24_09:20:44_BST [openHABian] Installing git package… OK
2019-10-24_09:21:07_BST [openHABian] Cloning myself… OK
2019-10-24_09:21:11_BST [openHABian] Executing ‘ unattended’. …
2019-10-24_09:21:11_BST [openHABian] Checking for root privileges… OK
Hit:1 buster InRelease
Hit:2 buster InRelease
Reading package lists…
2019-10-24_09:21:19_BST [openHABian] Loading configuration file ‘/etc/openhabian .conf’… OK
2019-10-24_09:21:19_BST [openHABian] Setting timezone based on IP geolocation… OK (Europe/Brussels)
2019-10-24_10:22:20_CEST [openHABian] Setting locale based on openhabian.conf… OK
2019-10-24_10:23:39_CEST [openHABian] Setting hostname of the base system… OK
2019-10-24_10:23:40_CEST [openHABian] Setting the GPU memory split down to 16MB for headless system… OK
2019-10-24_10:23:40_CEST [openHABian] Enabling Audio output… OK
2019-10-24_10:23:40_CEST [openHABian] Installing basic can’t-be-wrong packages ( screen, vim, …)… OK
2019-10-24_10:24:35_CEST [openHABian] Installing additional needed packages… O K
2019-10-24_10:24:57_CEST [openHABian] Installing additional bluetooth packages… . OK
2019-10-24_10:25:04_CEST [openHABian] Adding slightly tuned bash config files to system… OK
2019-10-24_10:25:04_CEST [openHABian] Adding slightly tuned vim config file to s ystem… OK
2019-10-24_10:25:04_CEST [openHABian] Downloading and setting up FireMotD… OK
2019-10-24_10:26:27_CEST [openHABian] Installing Java Zulu 32-Bit OpenJDK…
gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
2019-10-24_10:26:31_CEST [openHABian] Initial setup exiting with an error!”

I tried reflashing the SD card and running the setup again but that gives the same problem. I can see the error has to do with the Java installation. Can I install this manual and fix it like that? If yes how do I do that? I’m new at this so pls be gentle :wink:


Welcome to the openHAB Community :heart:

Could this be a duped topic?

Looks like it. Thanks for that.