Installation in Synology - Wrong Java version


(Marius Werth) #1
  • Platform information:
    • Hardware: Synology DS218+
    • Java Runtime Environment: Java 8-201 + Java 8-202
    • openHAB version: 2.3.0.005 syno + 2.4.0.000 syno + 2.4.0.001 syno

Hey everyone!

I’m trying to install openHAB on a Synology DiskStation DS218+. Unfortunately I always get an error, saying it’s the wrong java version.

I tried the two java version in the header in combination with three OH version, but always the same problem. I’m not the best in Linux things, so I don’t know how I can get to these log files :roll_eyes:

Does anyone figure out the same problem or is there anybody who can help me with that?

Thanks a lot!


(scott dee) #2

Maybe there’s an issue with that system being able to run it…not sure?
Check on this stuff in the picture. Be sure you have that java app (left) installed and that when you open it it looks like the portion on the right


(Marius Werth) #3

Hi!

Thanks for your fast answer!

OpenHAB_02

It’s the same version, but another build I think. I’m could just find 201 and 202, nothing older. Any ideas, where I can get older java version for testing? :face_with_raised_eyebrow:

Kind regards!


(Joseph) #4

Here is a list of older versions available, you just need to create an Oracle account to download (free): https://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html

BUT: I encounter the very same issue. I have downloaded different versions of Java (including the one from @waspie 's screenshot.

The error persists and seems to be unrelated to the installed version. Did you happen to find a solution?


(Marius Werth) #5

Hey, Joseph!

Thanks for the list! If you’re really encountering the same problem, I won’t test these other versions anymore. I switched over to Domotics again and I’m so glad that i was able to set up this system in the end.
But anyway, I’m open for solutions and tipps and would be happy to know if there are some other possibilities.

Good luck, and please tell me, if you find a solution :slight_smile:

Best regards,
Marius


(Joseph) #6

Hi Marius,

To begin with, I have to admit that I am no expert when it comes to Linux related topics. However, looking around quite a bit, I was able to determine the issue (or at least find a solution :wink: ).

The issue (at least I assume so), seems to be a missing correct link (symbolic link or symlink) to Java, which causes OpenHAB not to find the Java installation correctly.

I am quite certain that there is a SSH-solution to solve this (and anyone with slightly more Linux experience will likely find this to be the more obvious solution), but I preferred a very simple way:

  1. Uninstall Java from your Synology.
  2. Open Synology Package Manager and add the following package source (Package Manager --> Settings --> Package Sources --> Add): https://get.filebot.net/syno/
  3. From the “Community” part of the Package Manager, install “Java 8 Installer” from the author rednoah.

During the installation process, it will download and correctly install the latest Java version.

Afterwards, I was able to install OpenHAB without any issues. Let me know if it worked for you as well.

Cheers,

Joseph


(scott dee) #7

nice job! sorry I didnt chime in earlier…missed the notifications