Installed the MQTT Binding, but no mqtt.cfg file

then, no need to modify /etc/defaults/openhab2 file (since both 8080 and 8443 are free)

maybe the warning ({}: Address already in use) came because OH2 was re-started too fast (and port was kept occupied? (not sure))

Then I will be monitoring your last post for updates (edits) :slight_smile:

1 Like

I think that this was solved during a recent snapshot release (Issue)
If you want to be able to change the tcp ports on Ubuntu 16, you may need to use Snapshot release

You don’t have to, since it is not mandatory to change the ports in your system.

Anyway, I would recommend to switch to Snapshot to see if things improve.

Ps: after changing /etc/defaults/openhab2 (if needed), run also systemctl daemon-reload)

stop the service and try to see if /usr/share/openhab2/ gives any hints

check also: [SOLVED] "Failed to start The openHAB 2 Home Automation Bus Solution."

(might be relevant?)

You are welcome :slight_smile:

Try to clean up your openhab2.service also so it starts with systemctl
Maybe there is something left over from the first stable installation that doesn’t allow systemctl start openhab2 to work
after you check the file /usr/lib/systemd/system/openhab2.service for WorkingDirectory (/usr/share/openhab2) and ExecStart (/usr/share/openhab2/ server), do:

systemctl daemon-reload
systemctl enable openhab2
systemctl restart openhab2

Hi. I’m in a bit of a strange situation.I’ve installed Openhabian on my Raspberry and from Paper UI installed the MQTT Binding. The problem is, when i browse the services folder on my SD card the file mqtt.cfg is with .save extension. When i open the file with Visual Studion Code or nano the file is empty. I dont know how to configure my MQTT broker since the mqtt.cfg file is empty. If some could help it would be great!


An mqtt.cfg file would have been used with the version 1 mqtt binding.
With the version 2 binding you could install either the embedded mqtt broker or an external one like mosquitto.
Please read Here