Installing binding (network binding)

  • Platform information:
    • Hardware: Raspberry Pi
    • OS: Linux version 4.19.83-v7+
    • Java Runtime Environment: openjdk version “1.8.0_152”
    • openHAB version:

openHAB Distribution Version Information

build-no : Release Build
online-repo :

Repository Version

openhab-distro : 2.5.0
openhab-core : 2.5.0
openhab1-addons : 1.14.0
openhab2-addons : 2.5.0
karaf : 4.2.7

Short stroy:
I have troubles installing the network binding:
It doesn’t show up under Paper UI -> Add-Ons -> Bindings
It isn’t installed Paper UI -> Configuration -> Bindings
I don’t find a jar at to manually place in add-ons folder /usr/share/openhab2/addons/

Long story:
In my home/network I have a smart TV from philips. It’s going to deep sleep. In deepsleep, it can’t be powered on using the philipstv binding. I need wake-on-lan before. Binding installed and works fine, if the TV is on:

First task in the rule is to check if the TV is in deep-sleep.
I can do it with ping and iputils-arping from command line. I also can do it in a rule, example
executeCommandLine(“ping -c 1”, 60000)
But then I would need to write some code to parse the result. So I prefer to use the network binding - see “short story”.

Based on this result, I can execute the wake-on-lan:
sudo etherwake 44:D8:78:BD:xx:xx
This works with the TV via WLAN and settings Wake-On-WLAN.

Regards, Felix

Are you saying you want to use wake on LAN from the network binding? That wasn’t introduced until around OH 2.5.9 - it looks like you’re quite a few minor versions behind…

1 Like