• Platform information:
    • Hardware: Raspberry Pi 3 Model B / 1GB RAM / 32 GB SD Card
    • OS: Raspbian 9 (stretch)
    • Java Runtime Environment: openjdk 11.0.12 2021-07-20 LTS
      OpenJDK Runtime Environment Zulu11.50+19-CA (build 11.0.12+7-LTS)
      OpenJDK Client VM Zulu11.50+19-CA (build 11.0.12+7-LTS, mixed mode)
  • openHAB 3.1.0-1

I’ve recently upgraded to openHab 3.1. I was previously running openHab 2.5, including a working Insteon setup based around the latest hub (2245-222). I cannot get the Insteon things to ONLINE status. They’re all stuck at UNINITIALIZED (BRIDGE_UNINITIALIZED).

I have the following Insteon Bridge defined in main.things:

Bridge insteon:network:home [port="/hub2/**user**:**pass**@**hub_IP**:25105,poll_time=1000"] {

I have tried uninstalling and reinstalling the Insteon binding.
I have also tried stopping openHab, clearing the cache, and restarting.

Here are the log entries in events.log relevant to Insteon:

root@dlim_rp:/etc/openhab/services# grep -i insteon /var/log/openhab/events.log
2021-10-08 17:30:17.544 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'insteon:device:home:57682F' changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED)
2021-10-08 17:30:17.566 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'insteon:device:home:373855' changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED)
2021-10-08 17:30:17.570 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'insteon:device:home:576C8E' changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED)
2021-10-08 17:30:17.573 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'insteon:device:home:31DC79' changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED)
2021-10-08 17:30:17.577 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'insteon:device:home:33B445' changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED)

33B445 is the Insteon ID of the hub.

How do you have the items configured? I don’t see them in the Bridge code above. Until the bridge is initialized all associated devices will remain unitialized.

Can you also share what you see in events.log and openhab.log for insteon:network:home.

I don’t have explicit item definitions for the Insteon modules. In 2.5, all I had to configure was the Bridge thing. The Insteon modules, once connected to the hub, were autodiscovered. I have two dimmers, a motion sensor, and a plug module that are all already connected to the hub and interact with the Insteon app on my phone. In 2.5, that was sufficient, and everything initialized and was controllable in OH without needing explicit item definitions.

I didn’t notice in the documentation that Insteon items now need to be explicitly defined in an item file. I probably need to do that anyway since a minor annoyance when everything was running under OH 2.5, was that the Insteon plug module that I’m using for a coffee maker was getting default classified as a light, which resulted in the coffee maker getting grouped together with the other kitchen lights in Google Home.

The last line in the log (second code fence) is the bridge not initializing. Those five log lines are literally all that there is in event.log relevant to insteon.

I just noticed a weird thing. openhab.log hasn’t changed in over a month. the last mod date on openhab.log is Aug 4. openHab is clearly running, logging in events.log, and working for some things. Last night I got Google Assistant Actions working. I’m able to voice control four X10 lamp modules (via the old RS-232 firecracker/bottlerocket using the OH exec binding; not via Insteon/X10 support).

If you want to use auto discovery, don’t define the bridge in the config file. Add the Insteon Network manually from the UI. I wouldn’t mix both config file and ui configuration.

There has to be an insteon:network:home since that is how a Bridge is defined for the Insteon devices.

$ grep insteon:network:home *
events.log:2021-10-06 08:32:57.954 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'insteon:network:home' changed from UNINITIALIZED to INITIALIZING
events.log:2021-10-06 08:32:59.007 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'insteon:network:home' changed from INITIALIZING to UNKNOWN
events.log:2021-10-06 08:33:12.547 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'insteon:network:home' changed from UNKNOWN to ONLINE

Using the Insteon app is not supported. See Known Limitations and Issues

I’m not attached to autodiscovery. I think setting up the Things and Items in config files is going to give me more control over adding the necessary metadata in order to expose the items to Google Assistant.

I’m open to starting over from scratch on my Insteon setup, however, now I have leftover uninitialized Insteon Things listed in the UI that I can’t get rid of. I try to delete them from the Things listing, their status changes to “Removing”, but they never get fully removed. If I stop openHab, clean the cache, and restart, the Things go back to “Uninitialized” status after the restart. I have also tried deleting the Insteon binding (with the intent of reinstalling it after I get rid of the existing Insteon Things that I can’t get to initialize).

I’m not attached to using the Insteon app; I never had any intention of using the Insteon app for device control. I could be wrong, but I think at one point, the app was needed to link devices to the hub. I’ll check out Insteon Terminal. Is there anything I need to do either with Insteon or openHab to get rid of any interaction with the Insteon app other than just deleting the app?

Maybe the things are still in userdata/jsondb/org.openhab.core.thing.Thing.json. If they are, you could try editing the file and removing them. If that doesn’t work, maybe you can create a new topic and ask how to remove things that don’t go away. This is a core openHAB question, not specific to the Insteon binding.

All you need to do is delete the app.

Manually editing userdata/jsondb/org.openhab.core.thing.Thing.json and removing those Thing entries did the trick as far as getting rid of those Things listed in the UI was concerned.

I didn’t have a lot of stuff configured, so it wasn’t a huge effort to uninstall openHab, purge the old config files and rebuild everything from scratch. I now have the Insteon Bridge and child Things defined in a .things file and the hub, two dimmers, and the plug module are now all showing up as ONLINE in the UI.


1 Like