Insteon Binding: Item references unknown features

Hi all,

I have configured openHAB 1.7.1 on my raspberry pi, and have a few insteon devices installed in my home. I recently acquired the thermostat (2441TH) and configured it thanks to pfrommer’s guide and Insteon Terminal. Everything has connected O.K.

The problem I now have is when openHAB starts. I configured my .items file per the binding wiki, replacing the I.D with my thermostat:

Number  thermostatCoolPoint "cool point [%.1f °F]" { insteonplm="32.f4.22:F00.00.18#coolsetpoint" }
Number  thermostatHeatPoint "heat point [%.1f °F]" { insteonplm="32.f4.22:F00.00.18#heatsetpoint" }
Number  thermostatSystemMode "system mode [%d]" { insteonplm="32.f4.22:F00.00.18#systemmode" }
Number  thermostatFanMode "fan mode [%d]" { insteonplm="32.f4.22:F00.00.18#fanmode" }
Number  thermostatIsHeating "is heating [%d]" { insteonplm="32.f4.22:F00.00.18#isheating"}
Number  thermostatIsCooling "is cooling [%d]" { insteonplm="32.f4.22:F00.00.18#iscooling"}
Number  thermostatTempFahren  "temperature [%.1f °F]" { insteonplm="32.f4.22:F00.00.18#tempfahrenheit" }
Number  thermostatTempCelsius  "temperature [%.1f °C]" { insteonplm="32.f4.22:F00.00.18#tempcelsius" }
Number  thermostatHumidity "humidity [%.0f %%]" { insteonplm="32.f4.22:F00.00.18#humidity" }

Everything works except:

  1. thermostatSystemMode
    
  2. thermostatIsHeating
    
  3. thermostatIsCooling
    
  4. thermostatTempFahren
    
  5. thermostatTempCelsius
    
  6. thermostatBacklight
    

items that return this when I run openHAB with start.sh:

item (item name here) references unknown feature: (feature), item disabled!

for example. this is how it appears in my log exactly for SystemMode:

item thermostatSystemMode references unknown feature: systemmode, item disabled!

and so on for the above 6 items. Other things like humidity, set point, etc come in fine and are updated. Has anyone experienced this before? Is anyone aware of a solution?

Thanks.

What version of the binding are you using? Have you tried the latest 1.8 binding from cloudbees? https://openhab.ci.cloudbees.com/job/openHAB/

Rob

Hmm that seemed to do it, thanks. I didn’t see any mention in the documentation that 1.8 was needed. Thanks for the obvious tip.

The first paragraph in the wiki (https://github.com/openhab/openhab/wiki/Insteon-PLM-Binding) after the title has:

Note: this documentation is for OpenHAB v1.8. Documentation for OpenHAB 1.7 can be found here.

I updated the documentation and now it looks like a header. Hopefully this will help.