Insteon Hub with PLM: A Misprint in Wiki? (2012 v. has PLM)

According to the document:

This got me confused here: The 2242-222 Insteon Hub has PLM built-in, whereas the 2014 model, 2245-222, does not.

I’ve purchased a discontinued 2244-224 Starter Kit which has a 2242-222 hub and the Wiki should’ve state 2012 instead of 2014 for the hub.

Also, in the Insteon Hub binding, I’ve added insteonhub:host= to my openhab.cfg and added a single dimmer to the items file, but for some reason, it won’t respond when I click in the up/down arrows next to the item name. Do I need to link the hub to my LampLinc? It’s a 2242-222 model that I’m currently using.

Yes you need to link them. If you could access any Insteon device without linking then you could theoretically mess with your neighbors devices.

Use the InsteonPLM binding, it also works with the Insteon hub. The Insteon hub binding is basically not supported.

Then which ones (insteonplm:port_0=…) should I choose for connecting to my 2242 hub? I have assigned an IP address from my DHCP server, which is The dev lines are more for serial or USB and not for Ethernet. Do I simply enter insteonplm:port_0= in the OpenHAB config?

@Bernd_Pfrommer, can you help?

Well, must have missed the part after the linebreak, as if the raw tcp feed is separate from the above. Anyway, I’ve added insteonplm:port_0=/hub/ to the config but even though I’ve linked my Insteon 2242 hub to my LampLinc Dimmer, I still can’t get it to respond:

[code]Group Bedroom “Bedroom”

Switch ldBRLamps “Bedroom Lamps” (Bedroom) {insteonplm=“xx.xx.xx:F00.00.02#switc

(I’ve masked out the ID.)

sitemap default label="My Home" { Frame { Group item=Bedroom Label="Bedroom" Icon="bedroom" } }

Even though I have a dimmer, I’ve started out as a switch to test on/off; however, even with the correct ID, I couldn’t get it to respond.

So right now, I’m stuck.

And I do need to mention what Linux distribution I’m using. I’m using Arch Linux and installed OpenHAB from the Arch User Repository (AUR). The configuration is in /etc/openhab/configurations and there is an addons-enabled folder so I’ve copied the Insteon PLM .jar file from /opt/openhab-addons which I’ve also installed “openhab-addons” from the AUR as well, so it does not look like all the addons are enabled for OpenHAB after I’ve installed the addons.

I will need to troubleshoot the problem tomorrow. I will also change the subject of the thread as this thread deals with Wiki. That caused me confusion as I thought the Wiki talks about the PLM that is built right into the 2012 version. I must have mis-interpret the Wiki as saying the new 2014 version has PLM built-in, which it does not. I may need to re-read the Insteon Hub Binding page as that caused me confusion.

Couple of things:

  1. Make sure you are using Oracle Java, not Open JDK that is installed by default.

  2. Make sure you have the device paired both ways. Check out the openhab.log file and make you see something like:

2016-10-07 08:18:27.383 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - modem database has 61 entries!
2016-10-07 08:18:29.356 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - device 24.33.F7 found in the modem database and the modem controls groups [0xFE] and responds to groups [0x01].

Then a bit further down you’ll see something like:

2016-10-07 08:18:35.287 [INFO ] [.o.b.i.i.device.MessageHandler] - SwitchRequestReplyHandler: set device 24.33.F7 to OFF

If you see that, switch your device on/off and hopefully you’ll see the the on/off showing up in the log file.

Okay. I switched over to jre8.

grayson@home-server:/etc/openhab/configurations$ archlinux-java status Available Java environments: java-8-jre/jre (default)

I’ve uninstalled OpenJDK headless package that PKGBUILD pulled in for installing OpenHAB.

And there are no log entries for InsteonPLM:

grayson@home-server:/etc/openhab/configurations$ cat /opt/openhab/userdata/logs/openhab.log | grep InsteonPLM

Any pointers to know what’s going on? I have the addons installed, so how do I know if OpenHAB detected the list of addons?

Okay, so I’ve decided to do some investigation…

grayson@home-server:/etc/openhab/configurations$ cd .. grayson@home-server:/etc/openhab$ ls -l addons-enabled/ total 240 -rw-r--r-- 1 root root 244547 Oct 7 22:33 org.openhab.binding.insteonplm-1.8.3.jar grayson@home-server:/etc/openhab$ ls -l total 8 drwxr-xr-x 2 root root 4096 Oct 7 22:33 addons-enabled drwxr-xr-x 8 root root 4096 Oct 7 22:22 configurations grayson@home-server:/etc/openhab$ ls -l /opt/openhab-runtime/ LICENSE.TXT contexts/ sounds/ README.TXT etc/ start.bat webapps/ addons/ logs/ workspace/ configurations/ server/ start_debug.bat grayson@home-server:/etc/openhab$ ls -l /opt/openhab-runtime total 64 -rw-r--r-- 1 root root 11232 Oct 7 22:16 LICENSE.TXT -rw-r--r-- 1 root root 652 Oct 7 22:16 README.TXT drwxr-xr-x 2 root root 4096 Oct 7 22:16 addons lrwxrwxrwx 1 root root 27 Oct 7 22:16 configurations -> /etc/openhab/configurations drwxr-xr-x 2 root root 4096 Oct 7 22:16 contexts drwxr-xr-x 2 root root 4096 Oct 7 22:16 etc drwxr-xr-x 2 root root 4096 Oct 7 19:59 logs drwxr-xr-x 6 root root 4096 Oct 8 09:19 server drwxr-xr-x 2 root root 4096 Oct 7 22:16 sounds -rw-r--r-- 1 root root 996 Oct 7 22:16 start.bat -rwxr-xr-x 1 root root 926 Oct 7 22:16 -rw-r--r-- 1 root root 1146 Oct 7 22:16 start_debug.bat -rwxr-xr-x 1 root root 1132 Oct 7 22:16 drwxr-xr-x 4 root root 4096 Oct 7 22:17 webapps drwxr-xr-x 3 root root 4096 Oct 7 15:54 workspace grayson@home-server:/etc/openhab$ ls -l /opt/openhab-runtime/addons/ total 4 -rw-r--r-- 1 root root 126 Oct 7 22:16 README lrwxrwxrwx 1 root root 27 Oct 7 22:16 addons-enabled -> /etc/openhab/addons-enabled

So I would suspect Insteon will work since the addon is in the addons-enabled folder! “But wait! What if I do this and then restart OpenHAB,” I thought…

grayson@home-server:/etc/openhab$ sudo cp addons-enabled/org.openhab.binding.insteonplm-1.8.3.jar /opt/openhab-runtime/addons/ [sudo] password for grayson: grayson@home-server:/etc/openhab$ sudo systemctl restart openhab

20 seconds later, I am able to flick the light on and off and IT WORKED!!!

The addons have to be in the addons folder; not in the addons-enabled folder that is symbolically linked to /etc/openhab/addons-enabled…!!! I need to investigate what’s going on in the PKGBUILD and make a comment about it in the AUR. I cannot believe I got stuck in this and then it hit me so hard!

Anyway, thanks guys for your help.

Okay. Here’s the AUR package for the OpenHAB runtime:

I then did an investigation into PKGBUILD and here’s what I found:

package() { cd $pkgdir mkdir -p opt mkdir -p etc/openhab/addons-enabled mkdir -p etc/conf.d mkdir -p usr/lib/systemd/system cp $srcdir/openhab.service usr/lib/systemd/system cp -r $srcdir/openhab-runtime opt cp $srcdir/openhab etc/conf.d mv opt/openhab-runtime/configurations etc/openhab/configurations ln -s /etc/openhab/configurations opt/openhab-runtime/configurations ln -s /etc/openhab/addons-enabled opt/openhab-runtime/addons }

Take a look at the last line before the }. The addons folder already exist in the file system. So, I’ve been thinking. Instead of the one above, I would do this:

package() { cd $pkgdir mkdir -p opt mkdir -p etc/conf.d mkdir -p usr/lib/systemd/system cp $srcdir/openhab.service usr/lib/systemd/system cp -r $srcdir/openhab-runtime opt cp $srcdir/openhab etc/conf.d mv opt/openhab-runtime/addons etc/openhab/ mv opt/openhab-runtime/configurations etc/openhab/ ln -s /etc/openhab/configurations opt/openhab-runtime/configurations ln -s /etc/openhab/addons opt/openhab-runtime/addons }

And that should work, although I will have to uninstall OpenHAB and test out my modifications.

My conclusion is OpenHAB will not look into addons-enabled folder inside the addons folder and the submitter and maintainer of the AUR package made a mistake in PKGBUILD.

I will change the wiki for the insteonhub binding to mark it as obsolete. It is no longer supported.

That should clear up the confusion. Thanks.