Insteon Setup for a complete beginner

Thanks for the help, I will work on it tonight a bit, and well see where I get.

This tells you that the device is properly linked, so the problem isn’t with the hub.

Where is your config file? It needs to be in the directory conf/items and must end with “.items”. For example my file is called “default.items”. If it’s loaded, you’ll see an entry in the log file similar to:

2018-10-14 09:19:02.459 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'default.items'

I think I got it figured out, I’ll work on it later today some more. I think the problem was related to switch type

I had this
should have been this

But I still don’t see anything in the “Paper UI”?, just in the Sitemap that I created?

This is a 1.x binding there will be nothing in paper ui.

Hey guys, I’m starting from the beginning and feeling the same frustrations as the first post. This group of posts has been very helpful, but I’m getting some different log messages that I can’t figure out.

I’m at the very beginning; I have only configured the ‘insteonplm.cfg’ file with the username and password found on the bottom of my 2014+ hub2 and IP address. When I reboot and run openHAB start.bat (Windows install), I see this in the log:

2018-10-18 21:04:26.251 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: port_0 -> /hub2/my-username:my-password@,poll_time=1000
2018-10-18 21:04:26.262 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: -> org.openhab.insteonplm
2018-10-18 21:04:26.308 [INFO ] [b.core.service.AbstractActiveService] - InsteonPLM has been started
2018-10-18 21:04:26.310 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices:   0 configured,   0 polling, msgs received:     0
2018-10-18 21:06:26.355 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!
2018-10-18 21:08:26.377 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!
a ton of [TRACE] messages
2018-10-18 21:14:26.312 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices:   0 configured,   0 polling, msgs received:   595
2018-10-18 21:14:26.405 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!

In between the INFO and WARN messages, I had turned on TRACE messages using:

log:set TRACE org.openhab.binding.insteonplm

There are a ton of items, which makes it seem like it is indeed communicating (the 2nd to last message above about receiving 595 messages). Common lines like:

2018-10-18 21:13:13.571 [TRACE] [nplm.internal.driver.hub.HubIOStream] - no wrap:      appending new data: 026A060257EB000ED466011735
2018-10-18 21:13:13.573 [TRACE] [steonplm.internal.message.MsgFactory] - read buffer: len 13 data: 02 6A 06 02 57 EB 00 0E D4 66 01 17 35 
2018-10-18 21:13:13.573 [TRACE] [steonplm.internal.message.MsgFactory] - header length expected: 2 extended: false
2018-10-18 21:13:13.573 [TRACE] [steonplm.internal.message.MsgFactory] - msgLen expected: 3
2018-10-18 21:13:13.573 [TRACE] [steonplm.internal.message.MsgFactory] - keeping buffer len 10 data: 02 57 EB 00 0E D4 66 01 17 35 
2018-10-18 21:13:13.573 [TRACE] [ding.insteonplm.internal.driver.Port] - signaling receipt of ack: true
2018-10-18 21:13:13.573 [TRACE] [steonplm.internal.message.MsgFactory] - header length expected: 2 extended: false
2018-10-18 21:13:13.573 [TRACE] [steonplm.internal.message.MsgFactory] - msgLen expected: 10
2018-10-18 21:13:13.573 [TRACE] [steonplm.internal.message.MsgFactory] - keeping buffer len 0 data: 
2018-10-18 21:13:13.574 [DEBUG] [g.insteonplm.InsteonPLMActiveBinding] - got msg: IN:Cmd:0x57|RecordFlags:0xEB|ALLLinkGroup:0x00|LinkAddr:0E.D4.66|LinkData1:0x01|LinkData2:0x17|LinkData3:0x35|
2018-10-18 21:13:13.574 [TRACE] [ding.insteonplm.internal.driver.Port] - enqueued msg: OUT:Cmd:0x6A|
2018-10-18 21:13:13.574 [TRACE] [steonplm.internal.message.MsgFactory] - msgLen expected: -1

I have not configured anything else; no .items, sitemap, etc…don’t even know what those are yet! I’m just trying to get a good connection status.

Any ideas on this one? Thanks!


Tom have you paired anything with your modem?

You do this by pressing the link button on modem and link button on device you are pairing?

Looks to me like you have communication you just don’t have a database in the modem. This may be bacause nothing is paired.

Danny, Well…I have used the Insteon Hub App on my Android phone for a few years now and have complete control of my house devices through the app. So I assumed that that would have made the modem a controller of those devices and would set up the internal database, no?

I may just try doing what you said with one device and see what happens.

I was just assuming I’d see a successful status message, but that there were no entries set up.



Ok, I linked one SwitchLinc by pressing the set button on the Hub until it beeped and the front green light started flashing. Then I pushed the set button on the SwitchLinc until it beeped, and the Hub beeped and stopped flashing.

Then I stopped and restarted OH. I turned on DEBUG logging. I’m seeing this…

2018-10-19 21:48:34.234 [INFO ] [nding.insteonplm.InsteonPLMActivator] - Insteon PLM binding has been started.
2018-10-19 21:48:34.301 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - dead device timeout set to 3000s
2018-10-19 21:48:34.302 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: port_0 -> /hub2/Terryn73:B3tBRrBF@,poll_time=1000
2018-10-19 21:48:34.308 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: -> org.openhab.insteonplm
2018-10-19 21:48:34.415 [INFO ] [b.core.service.AbstractActiveService] - InsteonPLM has been started
2018-10-19 21:48:34.422 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices:   0 configured,   0 polling, msgs received:     0
2018-10-19 21:49:10.799 [DEBUG] [g.insteonplm.InsteonPLMActiveBinding] - got msg: IN:Cmd:0x57|RecordFlags:0xE2|ALLLinkGroup:0x00|LinkAddr:33.83.16|LinkData1:0x01|LinkData2:0x20|LinkData3:0x44|
2018-10-19 21:49:10.802 [DEBUG] [ding.insteonplm.internal.driver.Port] - writing (0): OUT:Cmd:0x6A|
2018-10-19 21:49:11.804 [DEBUG] [g.insteonplm.InsteonPLMActiveBinding] - got msg: IN:Cmd:0x57|RecordFlags:0xA2|ALLLinkGroup:0x01|LinkAddr:33.83.16|LinkData1:0x00|LinkData2:0x00|LinkData3:0x00|
2018-10-19 21:49:11.804 [DEBUG] [ding.insteonplm.internal.driver.Port] - writing (0): OUT:Cmd:0x6A|
2018-10-19 21:49:12.809 [DEBUG] [g.insteonplm.InsteonPLMActiveBinding] - got msg: IN:Cmd:0x57|RecordFlags:0xA2|ALLLinkGroup:0x01|LinkAddr:21.D0.99|LinkData1:0x00|LinkData2:0x00|LinkData3:0x00|
2018-10-19 21:49:12.810 [DEBUG] [ding.insteonplm.internal.driver.Port] - writing (0): OUT:Cmd:0x6A|
2018-10-19 21:49:13.814 [DEBUG] [g.insteonplm.InsteonPLMActiveBinding] - got msg: IN:Cmd:0x57|RecordFlags:0xE2|ALLLinkGroup:0x13|LinkAddr:33.83.16|LinkData1:0x01|LinkData2:0x20|LinkData3:0x44|
2018-10-19 21:49:13.814 [DEBUG] [ding.insteonplm.internal.driver.Port] - writing (0): OUT:Cmd:0x6A|
2018-10-19 21:49:14.819 [DEBUG] [g.insteonplm.InsteonPLMActiveBinding] - got msg: IN:Cmd:0x57|RecordFlags:0xE2|ALLLinkGroup:0x14|LinkAddr:1E.04.61|LinkData1:0x01|LinkData2:0x1E|LinkData3:0x41|
2018-10-19 21:49:14.819 [DEBUG] [ding.insteonplm.internal.driver.Port] - writing (0): OUT:Cmd:0x6A|
2018-10-19 21:49:15.823 [DEBUG] [g.insteonplm.InsteonPLMActiveBinding] - got msg: IN:Cmd:0x57|RecordFlags:0xE2|ALLLinkGroup:0x14|LinkAddr:29.E0.03|LinkData1:0x01|LinkData2:0x20|LinkData3:0x41|
2018-10-19 21:49:15.823 [DEBUG] [ding.insteonplm.internal.driver.Port] - writing (0): OUT:Cmd:0x6A|

150 lines of similiar messages, and then...

2018-10-19 21:50:34.435 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!
2018-10-19 21:50:34.435 [DEBUG] [ding.insteonplm.internal.driver.Port] - clearing modem db!
2018-10-19 21:50:35.225 [DEBUG] [g.insteonplm.InsteonPLMActiveBinding] - got msg: IN:Cmd:0x57|RecordFlags:0xA2|ALLLinkGroup:0x02|LinkAddr:4E.20.15|LinkData1:0x00|LinkData2:0x00|LinkData3:0x00|
2018-10-19 21:50:35.226 [DEBUG] [ding.insteonplm.internal.driver.Port] - writing (0): OUT:Cmd:0x69|

And then more of the same, repeatedly.

Browsing to the IP address and port 25105 and typing in username/password from bottom of Hub (same as in the .cfg) gives the following info, so I know the login is correct:

PLM Version:A4
Firmware:1017 Build Jul 18 2018 11:21:u5408:

Any other ideas?


I ran into a similar issue also. I had devices in the app but did not see them in openhab. Later on it worked. So I am a little confused. I asked to setup with buttons as I was unaware that you had devices in the app already. I was trying what I knew worked for me.

I know when I had the firmware issue all the values you show look correct though. It definitely looks as if you have a connection issue.

Have you tried to use insteon terminal? The setup is similar make sure you shutdown openhab and the insteon app prior to connecting.

Can you message me you insteon plm file let me have a look?

Ok, progress…without doing anything!

I just let it sit overnight and run. When I checked on the logs just a bit ago, I saw different entries.

2018-10-19 22:21:22.471 [DEBUG] [ding.insteonplm.internal.driver.Port] - writing (0): OUT:Cmd:0x6A|
2018-10-19 22:21:23.328 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!

I saw those every 2 minutes, until...

2018-10-20 00:29:34.753 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - modem database has 11 entries!

and then the list of the 11 entries

It is very weird that it took over 2 hours without even touching it for it to all of a sudden pick up the entries.

However, I have 31 devices and 19 scenes according to the Android app. So I need to figure out where the other 20 devices are, but I’m guessing it has something to do with linking the modem to the device, which I can handle.

Has anyone seen this behavior before where it took 2 hours to work? Very strange!

Oh, and what you asked for, the only uncommented line in my insteonplm.cfg file is:


I have added one item to a “C:\ProgramData\chocolatey\lib\openhab\tools\conf\items\default.items” file…now I just have to figure out how to -see- this item in the web browser…?

Thanks for the help!

Well I believe you said this earlier. But I missed it. I wonder if windows is you issue. I have my openHAB instance running on a pi. I highly suggest doing one of two things.

  1. Install Ubuntu in a vm on windows.
  2. Buy a pi

Option 2 is the best. I just don’t trust openHAB on windows especially if you are new to openHAB. I myself have personally seen issues on windows that when I went to Linux disappeared.

Also, yes the stuff that is in the app but does not show in openHAB was what I experienced with the app. Funny thing though it seemed intermittent. So maybe I did something wrong.

Yea, I see some weird things going on. Like after that 1st two hours, it found 11 devices in the modem. Eventually, I rebooted. Again, it took about 2 hours to make the connection. But then it said it only found 10 devices. And 3 of those were new! So it found 3 new devices, but lost a couple from the previous. Just strange. And it’s not like it’s missing a particular device type; it has found the whole range of items I have (Leak sensors, LampLincs, SwitchLincs, FanLincs).

I think it’s time for a new thread to start on this topic…

Thanks for getting me to this point!


1 Like

Yes new thread! Definitely.

1 Like

Make sure you also add the insteonplm tag

1 Like

Any idea why I’m getting all of these messages when trying to do a modem.getdb()?

got unexpected msg: IN:Cmd:0x62|toAddress:27.4F.C5|messageFlags:0x0F=DIRECT:3:3|command1:0x19|command2:0x00|ACK/NACK:0x06|
got unexpected msg: IN:Cmd:0x50|fromAddress:27.4F.C5|toAddress:39.1A.B0|messageFlags:0x20=ACK_OF_DIRECT:0:0|command1:0x00|command2:0xFF|
got unexpected msg: IN:Cmd:0x62|toAddress:42.15.52|messageFlags:0x0F=DIRECT:3:3|command1:0x19|command2:0x01|ACK/NACK:0x06|
got unexpected msg: IN:Cmd:0x50|fromAddress:42.15.52|toAddress:39.1A.B0|messageFlags:0x25=ACK_OF_DIRECT:1:1|command1:0x00|command2:0x00|
got unexpected msg: IN:Cmd:0x62|toAddress:2B.3E.F0|messageFlags:0x0F=DIRECT:3:3|command1:0x19|command2:0x00|ACK/NACK:0x06|
got unexpected msg: IN:Cmd:0x50|fromAddress:2B.3E.F0|toAddress:39.1A.B0|messageFlags:0x20=ACK_OF_DIRECT:0:0|command1:0x00|command2:0x00|
got unexpected msg: IN:Cmd:0x62|toAddress:3B.F0.EB|messageFlags:0x0F=DIRECT:3:3|command1:0x19|command2:0x01|ACK/NACK:0x06|
got unexpected msg: IN:Cmd:0x50|fromAddress:3B.F0.EB|toAddress:39.1A.B0|messageFlags:0x27=ACK_OF_DIRECT:3:1|command1:0x00|command2:0x00|
got unexpected msg: IN:Cmd:0x62|toAddress:3B.F0.EB|messageFlags:0x0F=DIRECT:3:3|command1:0x19|command2:0x00|ACK/NACK:0x06|
19:15:15.761 [Thread-3] WARN us.pfrommer.insteon.msg.MsgReader - got unknown command code 3B
got unexpected msg: IN:Cmd:0x62|toAddress:2B.DC.D1|messageFlags:0x0F=DIRECT:3:3|command1:0x19|command2:0x00|ACK/NACK:0x06|
got unexpected msg: IN:Cmd:0x50|fromAddress:2B.DC.D1|toAddress:39.1A.B0|messageFlags:0x20=ACK_OF_DIRECT:0:0|command1:0x03|command2:0x00|
got unexpected msg: IN:Cmd:0x62|toAddress:2F.87.C2|messageFlags:0x0F=DIRECT:3:3|command1:0x19|command2:0x00|ACK/NACK:0x06|
got unexpected msg: IN:Cmd:0x50|fromAddress:2F.87.C2|toAddress:39.1A.B0|messageFlags:0x20=ACK_OF_DIRECT:0:0|command1:0x00|command2:0xFF|

Openhab running? Can only have one thing at a time.

I get those messages also sometime.

lm usb from insteon and I don’t know how to link in the services / insteonplm.cfg file.
I just want you to explain briefly how to do that step I would appreciate it

Can you start a new request with your specific details?