Insteonplm Binding - Ignored attempt to add duplicate port:

Tags: #<Tag:0x00007fc8fc33b180>

Platform information:

  • Hardware: Raspberry Pi 3 Model B version 1.2 (ARMv8, with 1GB RAM, and 64 GB microSD card)
  • OS: Raspbian 9 (Stretch)
  • Java Runtime Environment: java version “1.8.0_151”, Java™ SE Runtime Environment (build 1.8.0_151-b12), Java HotSpot™ Client VM (build 25.151-b12, mixed mode)
  • openHAB version: 2.1.0-1 wth openhab2-addons 2.1.0-1

Hello,

In /var/log/openhab2/openhab.log, I see the following warning upon startup

2017-11-16 13:06:12.794 [WARN ] [ng.insteonplm.internal.driver.Driver] - ignored attempt to add duplicate port: port_4 /dev/ttyUSB0

This is followed by:

2017-11-16 13:06:12.860 [INFO ] [onplm.internal.driver.SerialIOStream] - successfully opened port /dev/ttyUSB0

I understand the warning is ignored, but I’m interested in getting rid of it nonetheless. How can I do that? If I look at the cfg files under /etc/openhab2/services, I only see the correct entry of “port_0=/dev/ttyUSB0”.

For those that are curious, I was fiddling with the USB setting in an attempt to establish communication with the PLM. I eventually figured out that it was my JAVA settings,

Regards,
Burzin

Try using the advice from this post to clear the cache.

Hi @namraccr,

I cleared the cache, and restarted OpenHAB, but the warning persists. Do you have any other ideas? It occurred to me to check the DB files under /var/lib/openhab2/jsondb. However, I didn’t find anything promising there.

Regards,
Burzin

Did you do that in the right order? You should shut down OH, clear the cache, then restart OH.

If that’s what you did, then my only other idea is to check for other definitions that have a reference to “port_4” in your configs.

Hi @namraccr

Sorry for not being clearer. I did it the right order, but I reread the instructions and also deleted the directories under var/lib/openhab2/cache and /var/lib/openhab2/tmp this time. However, this has not fixed the problem either. I presume by other definitions, you mean the cfg files under /etc/openhab2/services. If so I checked these too, and didn’t find a reference to port_4 /dev/ttyUSB0.

Regards,
Burzin