Internal Server Error only on PC (Edge and Chrome)

Tags: #<Tag:0x00007efed84d0c78> #<Tag:0x00007efed84d0a20>

Hi…When I try to log in with PC, I always get internal server error. I already tried to delete all website-data (cookies etc.) but it doesn’t help…tried with two browsers…On ANdroid there is no Problem (in the same Network). So it’s either related to my device (PC) or something in the cloud…can someone help with the reasons for “internal server error”? Running openhab 3 in docker

I just tested internet explorer (old) and it seems o work…but chrome and edge don’t…

it can mean “everything”.
In case it works with IE as you wrote it looks like the browser sends different information to the server.
In my job I had a case where a script did not provide e.g. Language settings to the server.
This let the server return an internal server error.
So if you say that it works with one browser but not the others please check e.g. which header information is being send to the server as e.g. language settings.
As long as this is done via http and not https you can use a netowrk sniffer to compare the traffic.

1 Like

Can you tell me how exactly to do it? So I can provide more information on the error :-). Which sniffer should I use?

I am normally using wireshark which is available for linux, macos and windows systems.

1 Like

I wanted to try it today, but the error is gone…I haven’t changed anything (besides installing wireshark) as I can remember…would the wireshark-tracing help though?

no.

1 Like

okay it occurs again…can you describe me what to do?

Have you changed anything between it was working and the problem happens again ?

  • download wireshark
  • do a network trace with a browser that works
  • do a network trace with a browser that does not work
  • then compare the ( meta ) data that is sent to the server

Okay I don’t know what’s happening here, but it works again :man_facepalming:. I “hope” it happens again then I will instantly try to diagnose. Thanks for the help!