Intertechno devices and binding


renovation works and the ‘cheap’ thread reminded me of an old 433 MHz radio plug lying around.
These you can get in any local hardware store or online for sometimes as little as 5-10€.
Most use the Intertechno protocol and they’re said to work with the busware CUL (868 MHz) stick I own and the CUL Intertechno OH binding.
I cannot get it to work, though.

My plug is a Pollin 2605. I tried several settings according to the binding Wiki and this link, but I believe it to actually be a ELRO AB440 because the DIP switches look exactly like this. So I tried

Switch Funkstecker      "Funkstecker Pollin Test"    (Test)     { culintertechno="type=raw;address=FFFFFF0000;commandOn=0F;commandOff=F0" }

I believe my CUL stick to be configured correctly. Here’s what happens on switching ‘ON’:

2015-09-27 09:48:44.682 [DEBUG] [.o.b.i.i.CULIntertechnoBinding] - execute() method is called!
2015-09-27 09:48:44.850 [DEBUG] [o.o.i.t.c.i.AbstractCULHandler] - Sending raw message to CUL /dev/ttyACM0:  'isFFFFFF00000F
2015-09-27 09:48:44.852 [DEBUG] [o.o.i.t.c.i.AbstractCULHandler] - Requesting credit report
2015-09-27 09:48:45.185 [DEBUG] [o.o.i.t.c.i.AbstractCULHandler] - Received raw message from CUL: isFFFFFF00000F
2015-09-27 09:48:45.187 [DEBUG] [o.o.i.t.c.i.AbstractCULHandler] - Requesting credit report
2015-09-27 09:48:45.210 [DEBUG] [o.o.i.t.c.i.AbstractCULHandler] - Received raw message from CUL: 21  900
2015-09-27 09:48:45.211 [DEBUG] [o.o.i.t.c.i.AbstractCULHandler] - credit10ms = 900
2015-09-27 09:48:45.233 [DEBUG] [o.o.i.t.c.i.AbstractCULHandler] - Received raw message from CUL: 21  900
2015-09-27 09:48:45.248 [DEBUG] [o.o.i.t.c.i.AbstractCULHandler] - credit10ms = 900

Has anyone gotten these thingies to work with openHAB ? Or anyone to share experiences on the CUL Intertechno binding ?


Did you ever mange to make this work?


Never saw this old thread (I started later).
My Elro plugs works with this Item setting from a Busware CUL866.

Switch Elro_Weiss "Elro-Weiss" (gLichtschalter) {culintertechno="type=raw;address=00000FFF0F;commandOn=FF;commandOff=F0"} /* Intertechno Code A15, Elro weiß */

The CUL is indeed the problem. I tried another one (CUL866 just like you @opus) and it worked at the first go.

1 Like

I flashed the nanoCUL with the latest firmware and it now works, too :slight_smile: