IntesisHome SessionID error

Im hoping someone here can point me in the right direction to get an IntesisHome working with OpenHab.

I have installed the IntesisHome physical device and can connect and control my AC from the Intesis AC Cloud app. The AC unit is Fujitsu, Openhab shows the modelID as FJ-RC-WIFI-1B

I have installed the Intesis binding, and the added the Thing both via GUI and file, however Im getting the same error with both. The logs go
Uninitialized → Initializing
Initializing → Unknown
Unknown → Online
Online → Offline (communication_error): Request unsuccessful
Offline (commincation_error): SessionID not received.

OpenHab is picking up the MAC Address, Serial number, firmware version etc of the device so is communicating with the IntesisHome to some degree.
An nmap scan shows port 80 open (tcp).
Im probably missing the obvious, any hints or clues would be most appreciated.


Please set log level to trace for the intesis binding and post the logs.

Thanks for you help, logs below

My password is the same one I use to log into Intesis AC Cloud

Please don’t post logs as screenshot but plain text in between code fences. It is really hard to read the logs.

Please try to setup the device as “IntesisBox”, as per maual, it seems not to be a “IntesisHome” device.
IntesisHome Devices are directly connected to the AC and do not have external power supply or DIP switches.

Thanks for your help.
The device type straight off the packaging is IS-RC3-RS485-WIFI-1-V2. Order code INWFIFGL001R000. Im pretty sure AC Cloud is just renamed IntesisHome. The device connects to the 3 wires running to the wall mounted controller (12V, bus, gnd). It has no external PS and has 2 banks of dip switches. One bank of 4 is for determining master / slave relationship, type of Fujitsu HP, wifi power etc. There was no documentation about the second back of 8-10 dip switches which I didnt touch.

I have tried a couple of options via the GUI with the resulting logs

==> /var/log/openhab/openhab.log <==
2022-03-09 11:29:53.558 [TRACE] [.internal.handler.IntesisHomeHandler] - request : '{"command":"getinfo","data":""}'
2022-03-09 11:29:53.639 [TRACE] [.internal.handler.IntesisHomeHandler] - request : '{"command":"login","data":{"username":"Admin","password":"xxxxxx"}}'
==> /var/log/openhab/events.log <==
2022-03-09 11:29:53.545 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisHome:0db4cfba86' changed from UNINITIALIZED to INITIALIZING
2022-03-09 11:29:53.559 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisHome:0db4cfba86' changed from INITIALIZING to UNKNOWN
2022-03-09 11:29:53.639 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisHome:0db4cfba86' changed from UNKNOWN to ONLINE
2022-03-09 11:29:53.707 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisHome:0db4cfba86' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Request unsuccessful
2022-03-09 11:29:53.711 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisHome:0db4cfba86' changed from OFFLINE (COMMUNICATION_ERROR): Request unsuccessful to OFFLINE (COMMUNICATION_ERROR): SessionId not received

One channel for Power was created, I linked it to an item but it didnt turn the power of the AC on / off

IntesisBox (default port 3310)

2022-03-09 11:33:37.238 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisBox:054f12daae' changed from UNINITIALIZED to INITIALIZING
2022-03-09 11:33:37.248 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisBox:054f12daae' changed from INITIALIZING to UNKNOWN
2022-03-09 11:33:37.257 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisBox:054f12daae' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Connection refused (Connection refused)

5 channels created. Linked Power item but doesn’t change power status of AC unit

IntesisBox (port 80)

2022-03-09 11:34:45.041 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisBox:83c19dc806' changed from UNINITIALIZED to INITIALIZING
2022-03-09 11:34:45.051 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisBox:83c19dc806' changed from INITIALIZING to UNKNOWN
2022-03-09 11:34:45.056 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'intesis:intesisBox:83c19dc806' changed from UNKNOWN to ONLINE

5 channels created. Link Power item but doesnt change power status of AC unit

I have recently upgraded to rpi4, on OH3.2. I did not have the Intesis device on OH2.x, Im just wondering if there is anything silly in my new OH3.2 configuration that I may have overlooked? Everything else I have got working after the normal upgrade tweaks :wink:
Thanks again

I am more convinced this is an username / password error. I found a script from @pelnet which I have managed to get running (well outside my comfort zone). Im using the same password I use to access Intesis AC Cloud, both web interface and App.

success : true
wlanSTAMAC : CC:3F:1D:03:3C:01
wlanAPMAC : CE:3F:1D:03:3C:01
ownSSID : DEVICE_033C01
fwVersion : 1.4.7; 1.3.3; 1.3;
wlanFwVersion : 2.0.0
wlanLNK : 1
ssid : Alkemy IoT
rssi : -49
tcpServerLNK : 1
localdatetime : Wed Mar 09 17:53:03 +13:00 2022 DST
wifiTxPower : 2
deviceModel : FJ-RC-WIFI-1B
sn : xxxxxxxxxx
ERROR: Authentication failed. Exiting.

I think the next step is some snooping to find out whats going on between my device and AC Cloud. Some new learning also for me!

@kiwi Glad you found the script useful. :slightly_smiling_face:

As for sniffing the traffic, that’s going to be a bit tricky as it’s all SSL. You might be able to do a man-in-the-middle with something like Squid using peek/splice, but it’s not going to be easy.

Keep me posted if you find anything useful.

The IntesisHome devices run a local web server on port 80. You need to provide the local credentials to the binding, not the cloud credentials.

That makes sense, however I don’t recall setting local credentials when I installed the device. Tomorrow I’ll reset the device and start from scratch and see if there is anywhere to set local credentials. I had “assumed” the the cloud credentials were passed to the device.

I have it working - thanks
I entered the password for the IntesisHome (guess). I do not recall seeing an option to enter the PW in the setup phase, it was either not there or I skipped over it in my haste to get the thing working. I may in the future do a factory reset to check where the PW is entered. I had assumed the PW for the cloud was passed to the box, alas that is not the case.

Great, so mark this topic as solved please…