iOS App, logs: Basic authentication with username/password is not allowed

Good morning

Added a simple watch.sitemap file and suddenly the iOS app shows a blank screen and in the logs I see constantly:

2022-11-13 10:47:02.106 [WARN ] [] - Unauthorized API request from Basic authentication with username/password is not allowed

Removing the watch.sitemap file doesn’t help…

The iOS app running on macOS works normally…

thanks for any hints

Did you turn on the Allow basic authentication in Setting => API Security ?


Great hint, struggled a while with the same problem and now the problem seems to be solved.

I first searched for “url session task failed” and all hints given in this discussion didn’t work.

For me I looks a bit strange, because I changed nothing, related to API security and it stopped working some day. I could not access the page from iPhone app any longer.
After having changed the home page and saved some other things I cannot remember in detail, it worked again, for about a day, then it stopped working again.

Thanks a lot

Has anyone got this to work? So vague the replies on what people have done. API Security is set to basic but it still fails on latest Stable release OH and latest Iphone app


I got the following error according to the openhab.log

[WARN ] [] - Unauthorized API request: Basic authentication with username/password is not allowed

After changing the settings the following:

  • Goto Adminstration/Settings/API Security and click the “Show advanced”
  • Activate “Allow Basic Authentication”

This solved it for me