iOS App shows `URLSessionTask failed with error Ungültige URL`

The openHAB iOS app is no longer working for me (an older version did in the past). I just receive URLSessionTask failed with error Ungültige URL

I already reinstalled the app (version 2.4.54) entered the remote access URL,
my username and password. I set always send login data (Anmeldedaten immer senden) true and cleared the web cache. Anyways I always receive said error message.

Here is what IS working:

  • I can login via browser with my credentials to
  • My OpenHAB installation is shown as online
  • I can see my dashboard via browser with

All my attempts to access the data this via the openHAB app result in the same error message. I emptied the list of the iOS devices on the website.
Even when I only receive the URLSession task error message there seems to be successful communication, as the iOS device showing up again in the list of devices after that.

Is there any way to debug what is happening? Can I make the iOS app make to show some logs?

There is a new version on the way. Testflight app is already working for some users (like me)

I updated to version 2.4.56 today and now it works without any other changes. Thanks for the heads-up