IP Camera Stream Causing Sitemap to not load and myOpenHAB to not respond

Hey guys,

I have been using BlueIris for about a year now and really like it so recently I tried to incorporate the camera streams into my OpenHAB sitemap. I was able to get it to work using some info I got off of this site but I think it had a side effect.

While I was configuring the sitemap elements, I was on LAN and all worked fine but then I left and tried to check the cameras from outside my home, I found that my sitemap didn’t even load in the iOS app. It was just a black screen waiting for it to load in but never did. Then I went back home and logged into myopenhab.org form LAN to load the sitemap from there (same place my app was pulling it from). It didn’t load there either. I couldn’t even get to the screen where I can see the green ONLINE flag at the top of the screen

I was able to get it to load on LAN using the local IP. In looking at the logs, looks like there were several messages that said. There was a pair of these messages about every minute.

Disconnected from the openHAB Cloud Service (UUID XXXXXX…)
Connected to the openHAB Cloud Service (UUID XXXXXX…)

I checked the CPU of the server running OH 2.5 and it was hovering at ~10% CPU usage. I was able to restart the server and get access to the sitemap via myopenhab but it immediately became laggy again and the same problem arose.

I have temporarily removed the camera feeds from my sitemap and so far that has fixed the issue.

Is the OpenHAB cloud service and or MyOpenHAB.org not capable of carry thing these video loads? Anyone else have experience with this?

for those interested, the URL I used to get the camera feeds is this:


I should note that I had my sitemap configured to only show 1 camera at a time by using clickable text elements.

EDIT: forgot to mention that i am running OH 2.5.10 release build