iPhone + Unifi Binding :online is rolling. Getting online and offline

Hi all,

I had a great plan: When I get home I park my car in front of my house. My smartphone iphone connects via wifi to the network and my openhab knows: ah, he is home - i ll turn on the light for getting in.

More or less this works.

But my problem is: my smartphone keeps to get offline and online again and so my light in front of my house turns on and because of my .rules-file automaticly after some minutes off.

My theory: Apple tries to save power to put my smartphone into a low-wifi-mode…?

I was unable to see that Behaviour by watching the unifi-controller. There my phone seems to stay awake and online (but I am not 100% sure, since the timing is quite complicate…).

I do not post my items and things-file, since its nearly the same as the unifi-binding-docs.

Anyone with same issue or any ideas to solve it?


I don’t have this issue with my controller. You could try disabling UAPSD on your wireless network. What do you have your “Consider Home” interval set to? Mine seems to work very well with the default 180 value.

Thank you for the quick answer.

Refresh is set to 10 and considerHome to 180. I already tried to raise or lower both values… without success.

Before I search for it… do you know where I disable U-APSD on my controller?

It’s under Settings —> Wireless Networks —> [WirelessNetworkName] Edit —> UAPSD is under Advanced Options

Hm… I dont find that … Do you use the latest controller-version?

6.0.43. It’s unavailable in the app settings so you may have to visit the browser. Forgive the bad screenshot since it’s from my phone.

Found it - I needed to switch to the classic design of the controller…

But it already was turned off. So i tried to turn it on, maybe my phone ignored the capabilities of the access-point and so this helps. Maybe.

Thanks :slight_smile:

Have you been able to solve it?
I do have this problem as well….

No, I am sorry - not solved yet; but i also did not invest so much more time, since i planned to upgrade to V3 first… but if you have any further clue - let me know :slight_smile:

Just curious,

I suddenly have the issue with unifi controller. Did someone find a solution for this?

[edit] I’ve enabled the UAPSD option, seems that the phone goes into ‘energy save’ mode. but gets disconnected because of it’s unsupported (unchecked) in the controller.

Best regards,