Irregular problems with my relative humidity value % units which are always solved with a restart?

Hi openHAB-Community.
I have a problem since a long time which I just can’t solve.
I’m running openHAB 4.0.2 in a docker container on a Synology NAS DS 716+
The Homematic wall thermostat is connected through the CCU3 Firmware version 3.71.12.

I have read the value of the Homematic thermostat in the following item:

Number:Dimensionless    WT_Arbeitszimmer_Luftfeuchte                "Luftfeuchtigkeit WT Arbeitszimmer [%d %%]"                             <humidity>     (LuftfeuchteRelativMin,LuftfeuchteRelativMax,LuftfeuchteRelativ_Arbeitszimmer,WT_Arbeitszimmer)  ["Point"]      {channel="homematic:HmIPW-STH:ccu3:001D1A49905B3F:1#HUMIDITY", unit="%"}

If everything is correct the value is for example 64%.
After I run openhab for a while only some of my wall thermostat items show 0,64% instead of 64%.
This then crushes all my further calculations and so on.

Here the wrong version before a restart.

In my widget the value is then empty:

My widget configuration looks like this:

                      - component: f7-col
                            font-size: 1rem
                            - component: Label
                                  color: '= items["LuftfeuchteRelativ_""_")[1]].state > 60 ? "blue" : (items["LuftfeuchteRelativ_""_")[1]].state < 40 ? "brown" : "black")'
                                text: =items['LuftfeuchteRelativ_'"_")[1]].displayState

After a restart of openhab everything is fine again for a while:


Does anyone know the reason for this problem and has a bugfix for me?
Thank you so much for your effort!

I don’t know if metadata keys are case-sensitive. If they are, it should be unit rather than Unit. You could try changing it.

Thank you for your reply. My item configuration is file based and I have written the unit everywhere in lowercase letters. As you can see in my configuration example.
So I can’t optimize here and it can’t be the reason.
Any other ideas?

Sorry for misleading you. You are certainly right. It’s displayed as “Unit” in the UI when declared as “unit” in the .items file.

no worries. I’m happy about every idea which might point me to the cause of this problem. :slight_smile: