Is read only, or is it also possible to do actions / change config?

I’ve been working with a RPI3 + Openhabian for a while and everything seems fine, but when I try to configure anything through nothing happens. I can see all values, and everything gets updated, but I can’t change config, create things or items, search, or even activate an item through the Control in PaperUI.

I’ve tried everything in different fresh installs, which makes me think… is it normal and is kind of a “read only” service or should I be able to do changes?

Sorry Jordi, I recently had the same problem and nobody answered. I’m not sure if it’s general or if it only happens to some users, but looks like it’s been like this for almost a year, so if remote controlling is important to you, you’ll have to look elsewhere :(.

IMHO it is possible to create Things, but installing addons is not possible.

I just checked and I can switch things on and off through MyOpenhab.
I have never tried the PaperUI in myOpenhab before, simply because I even seldom try it locally, but I tried this time and it appears I can configure items

Thank you both for your answers.

Can you please try this through PaperUI => Configuration => System => Item Linking => Change ON/OFF position => Save button. In my case I don’t get the “save ok” answer, but a gateway error a while ago, while if I do it locally I get the “save ok” (or similar, I’m doing it from memory).

If it works, can you tell me what system are you using? Is it also RPI3 with Raspbian? Seems like @jordif and I are getting the same error with fresh installations :S

That seemed to work, did not get an error, but as I wanted to switch it off again and saw no possibility for that… I went to the local Paper UI and saw that it was still switched off

In my case the “Simple mode” isn’t saved, this result MIGTH be forced by my use of the addons.cfg file l, in which I saved the OFF fort that feature.

I think you both have the same problem. To me, it looks like it’s doing changes, but at the end it’s not.

@Kees_van_Gelder, did you get a “save ok” or similar in the bottom right of the screen just after clicking “save”? If not, I think you’ve got the same problem.

@opus, you can try it with any other option in System menu, if you’ve got the same problem, then you’ll see that in local PaperUI you’ll get a “save ok” message, but not in myopenhab… and after a while, all changes you’ve done will come back to original.

Nope, I didnt get the “save OK” and indeed it didnt save.

Actually I never considered it a problem as I never use PaperUI through myopenhab and actually seldom use it directly.
nevertheless if there is a ‘cure’ i’d be happy to implement it :wink:

I also hope there is a “cure” for that, in my case I can’t easily access to local PaperUI, and since I don’t have SMB access either, I can’t configure it through the distance :(.

BTW, you said before you can switch things on and off through MyOpenHAB. Did it actually work, or was it like this case that at the end it doesn’t? I’ve only tried in PaperUI => Control and it doesn’t work there, but didn’t get to try it in Basic UI either.


it worked, I saw a lamp go on and off

Oh, good, it’s something :). How did you trigger it? Basic UI? PaperUI => Control?

the lamp I just switched from the Basic UI. Didnt even know I could do that from paper UI

As far as I can say the control of the Channels that are displayed on the Control pane of PaperUI is possible. Even the creation of a discovered thing was possible. However the deletion of that thing was not possible as well as the installation of any addon was not possible while using PaperUI through myopenhab

Thanks. Doesnt really matter to me as I really never use the paperUI and certainly not the one on myopenhab :wink:

As far as I read in (, no configuration is supposed to be possible through myopenhab. Only the display and control of items exposed via GUIs are mentioned.

1 Like

Indeed, and that is exactly what I have been using it for. I have never felt the need to go configure my openhab when i was out and about/on the road :wink:

From this page I understood that by "It allows remote access to local openHAB instances " it meant I could do everything that it was possible in the local GUI :S

Still, in my case I can only Control and discover though local PaperUI, not in myopenhab. I’d say that I can’t do anything that means “changing” stuff, only reading.

Anyway, looks like I don’t have many choices to config remotely. I can’t open ports, since I’m in 4G and they don’t allow me todo that…

I was referring to a paragraph further down stating:

…which gives you remote web access to the web UIs of your openHAB runtime and also let’s you check for the state of exposed items, notifications and events.

When I’m trying to configure from remote I use a VPN.That works pretty good.

Thank you, I think I’m starting to understand it. However, as @mahonni said, that makes it hard for me to config OpenHAB remotely, since the only external access I can have is through myopenhab.

Too bad, since it looks like almost all work is done.