Is Qubino ZMNHOD1 working on OH2?

Hello all,

(with the kind help of the FHEM forum guys) I found only one z-wave module that seems to be able to control a 24V DC window open/close motor that needs polarity change to control the direction: The Qubino ZMNHOD1.

The recension on Amazon, however, says it’s not compatible with OpenHAB. So before buying it, I would be happy if somebody could let me know if they have that device working with OpenHAB 2 and are there any issues to be aware of?

Thanks a lot!

If it’s a zwave module it will be possible to add it to the zwave binding database and then it will work with OH. It may even work out of the box.

Adding a product to the database is pretty straightforward:

The Qubino ZMNHOB device is already in the database so it should be easy to add the ZMNHOB1

@vzorglub - ZMNHOB1 is working out of the box.

Hello @chris

I’m successfully using the ZMNHOB1 as Rollershutter item. However, the Watt usage is not read it seems. The Qubino manual states as well that in OpenHAB the wattage reading does not work (while Domoticz, e.g. is marked as working).

Is there anything I can do to help to add the wattage reading of the relay? Is there any info that would be useful for you? In the logs, the wattage is neither displayed nor is it in the PaperUI oder Habmin displayed with a value, though I added it as item.

Here’s the node.xml file:

node48.xml (14.3 KB)

From the XML it looks like the device is using the standard meter command class which works fine with most devices and I’m therefore not sure why it wouldn’t work here. I’m also pretty sure it works fine with other Qubino devices, so again, I don’t understand why this device would be different unless it’s somehow non-standard.

I would suggest to change to use the development binding (if you aren’t already) as this is the latest binding. If it’s still not working, then please provide a log showing the data that is received and I’ll have a look.

One point though - this device doesn’t seem to be in the database - at least not under the name ZMNHOB. Can you tell me what it’s actually called please?

Hello @chris

so - the Watt stuff is actually shown in paper UI and I get a zwave channel to add to my .items file, but it always stays 0.

The device is this one:

It seems from the product page that the number 1-8 describes the frequency used for Z-Wave.

If it’s 0, then this either means it’s not being updated, or it’s being updated, but the device is sending 0. Either way, a debug log is needed to find out what is happening.

What name does OH give it though? I’m trying to correlate this to the database entry so I can check if there’s anything wrong in the database. I tried searching for ZMNHOD, but this name is not in the database it seems.

Can you tell me which way I can best get the information you need? I assume somehow through Karaf (I know how to log in there), but how can I best give you then just what you need. I don’t know the commands so you get the debug output you need.

In Paper UI I see:

Z-Wave Node 48: ZMNHOD Flush Shutter DC

ZMNHOD Flush Shutter DC
Flush Shutter DC

Log in to Karaf and enter the following command -:

log:set debug org.openhab.binding.zwave

This will now start logging more data to the openhab.log file (it can get big). Now we need to see if the device is sending data or not - this is just about time. If it’s not, we need to find out what the initialisation is doing and there is an option in the HABmin menu called “reinitialise device” (you need to select advanced mode to see it) and clicking this will re-run the initialisation which may also be useful to find out what is happening with the device.

Ah - ok, I searched for ZMNHOB which I copied from your post above -:

OK - I will let it run today over the afternoon and report back what it says. Anything special I should grep for in the log file (as I assume you don’t want my whole log file)?

Well, I want a log that is not filtered (ie what ever you provide should not have been grep’d as this will almost certainly remove information I need).

That said, if you run for a day, the log could be long. If it’s less than 10 to 15 MB, then it’s fine - just send it over (somehow!). If it’s much bigger, then it should be sliced into different files by OH so that each file is 10MB and it would be good to send only one that has what we want. Assuming the logs run for an hour or two, then if the device is sending data, it should be in there. If you do an initialisation, then ensure that the log you send has this in it (or if it spans two logs, then feel free to send both).

Hi @chris

ah - okay. I sent you a grep’d log for that node. I’ll be recording things now and send you one as you said in you post without grepping.

Ok - if you prefer to email to me directly, then feel free (chris -at- I can accept large files via email (I forget the limit - 15MB I think).