Issue with commanding heat pump

I was also thinking about leveraging warmer outdoor temps and/or PV energy for water heating with my Bosch heat pump. Shifting water heating into the day hours seems to be a quite easy but helpful method.
I just tried dwh1_Charge.sendCommand(“start”) and expected that is starts heating up directly, but nothing happened.

When I tried it, dhw1_currentSetpoint was 60, and dhw1_actualTemp was 52.

Whyt could I do wrong? Or does my device not support it? The gateway info is

Hi @SimiWest ,

without knowing the details of your hardware, I just guess that the command you send is not understood. I assume the Item you send the command to is of type Switch. In this case, the command you need to send is ON (without quotes). Try


and check whether this works.

For more details you might need to check the documentation of your binding, whether it supports writing data to the device at all. There are bindings around that only support read access, and other bindings where only parts of the supported things allow to be written.

Hello, are you aware of this solution? Works nicely with my ground source heat pump, dishwasher, washing machine, and electric car charging.

Thanks for your hints. I was assuming that the heating system is smart enough to be controlled via openhab binding. I’m not really into soldering something :wink:

It turned out that start command works under certain conditions. My system is a combined one with a heat pump and a gas burner. It’s currently configured for hot water in this way:

  • gas burner heats up water every monday 5am for thermal desinfection
  • rest of the time the heat pump is doing this, but with a lower temperature

The time, in which hot water should be available has been limited on the appliance to 12-19. That was my attempt to use solar energy instead of letting the heat pump do this during night.

I now realized that sending the command “start” during this timeframe works! But sadly it used the gas burner. But maybe this is because a temperature setpoint was used that is above the temperature that the heap pump should produce. I have to see if I can twek that.