Issues with Fibaro Rollershutter FGR-222

Hi there,

I’m using OH 1.8.3 and I’m using zwave binding version according to habmin. Habmin presents itself as version though the corresponding jar file within my addons folder is called… I cannot really explain this :slight_smile:

I already have some devices up and running fine, including a Fibaro FGR-222 rollershutter in my daughter’s room. I now received two more of these items and an electrician, who also took care of the one running fine, wired them up in my living room. I’ve then set my controller (Aeon Labs stick) into include mode and found one of the two that I can now control via a corresponding item+sitemap. It’s somehow strange that the directions are mixed up - Moving the roller shutter downwards requires pressing the up arrow and vice versa. I guess that this can somehow be configured anywhere?

My second problem is that I just cannot detect the second rollershutter via habmin. Activating the roller shutter during inclusion doesn’t make any difference, unfortunately. openhab.log also doesn’t provide any useful information.
When inspecting the packaging a bit deeper, I recognized one of my three controllers carrying the information “v2 5” while the other’s are only identified by FGR-222.
From what I’ve read so far, this version had been added for an older snapshot of the z-wave binding already, so I don’t really understand what might be going wrong here.

It would be great if someone had an idea of what to try out in order to solve these problems as I’m running out of ideas currently… Many thanks in advance!


invert_state=true can be used to invert the state of a multilevel switch command class. eg this can be used to reverse the direction of a rollershutter.

Many thanks, @sihui, this solved it for me. :slight_smile:

One problem resolved, one left: The missing FGR-222 v2 5. Might be due to the antenna’s direction or something?
Or maybe the inclusion process itself: In the manual, it’s said that the controller should be set into inclusion mode and then power consumption to the FGR should be established - Therby, the device would be added by the controller. So far, all FGRs were wired first and then I’ve activated inclusion mode via habmin. This worked out fine for two of the FGRs, but maybe v2 5 behaves differently in that regards? Any experience?
Thanks a lot again!

Short update on this one: Nothing of what I had thought of in my post above helped. Together with the electrician, we’ve pulled the actor out of the wall again and I’ve tried to include it - failed. We’ve taken away the power consumption, set the controller into include mode and than added power consumption again - failed. We’ve tried moving the roller shutter up & down with controller in include mode - failed.
it works well with the push switches on the wall, but it just won’t be found by HABMin.
Has anybody any idea what I could try out or where I could find information that could help me solving this? Or is my device just broken?
I remember that I had ordered 2 FGRM-222 and received one that had this “v2 5” on the packaging - Any idea where/how to prevent receiving this v2 if it’s not working properly?
Many thanks for your support!

Didn’t you triple-click the button when the controller is in inclusion mode (you didn’t mention) ?.
Enable zwave DEBUG level in logging to see if there’s any communication at all.
If that doesn’t show anything, then possibly it’s out of range for inclusion. Move your OH zwave controller over to the FGRM or vice versa before trying to include it.

@mstormi: I’m feeling really ashamed now. Triple clicking resolved everything. I was so focused on the auto inclusion that I have apperently completely overseen the manual inclusion option of triple clicking the up button. Works like a charm now. Many thanks!!!