Issues with openhab app / basicUI

I’m running openhab 2.2 inside a docker on an unraid machine with more than enough power (ryzen 7 1700X, 16 GB RAM, etc) and I’ve mostly been ok, but had a few issues recently popping up.

My basic UI still works, but on mobile I just started getting a message along the bottom of the screen “Offline: waiting for connection to become available” I haven’t been able to nail down the cause of this. I was getting some errors in the log from a milight binding (which still works), however removing this binding didn’t fix the issue.

Since this error started all the openhab phone apps I have tried display the sitemap, but don’t actually work to switch anything. The switch appears to work in the app, but doesn’t control the device, and when the app refreshes the state goes back.

Sitemap posted below:

sitemap default label="Custom Home Layout"


    Frame label="Lounge" icon="light" {
    Switch      item=harmonyhub_device_LoungeRoom_39200728_buttonPress label="Air Conditioning" icon="climate" mappings=["25 Degrees"="On","Off"="Off"]
    Selection   item=harmonyhub_hub_LoungeRoom_currentActivity label="Harmony" icon="player"  mappings=["Use Shield"="Use Shield","Play PS4"="Play PS4", "Power Off"="Power Off"]
    Switch      item=SS_Lounge_Shelf_Lights     label="Shelf Lights"
    Switch      item=milight_rgbwwLed_ed6eeb88_2_ledbrightness label="Aquarium" 
    Slider      item=ML_Aquarium_Dimmer label="Aquarium Brightness"
    Colorpicker item=ML_Aquarium_Color label="Aquarium Colour"

    Frame label="Bedroom" icon="bedroom" {
    Switch      item=harmonyhub_device_Bedroom_52279315_buttonPress label="Air Conditioning" icon="flow" mappings=["25 Degrees"="On","Off"="Off"]
    Selection   item=harmonyhub_hub_Bedroom_currentActivity label="Harmony" icon="player"  mappings=["Use Plex"="Use Plex","Play PS4"="Play PS4", "Power Off"="Power Off"]
    Switch      item=SS_Bedroom_Lamp label="Lamp" icon="light"



I have the “offline” error too, although I am using Build #1241, so possibly the problem has been fixed.

What is the memory/CPU usage of OH?

Is the mobile connecting locally or through

The behavior sounds a lot like you have some sort of networking issue between the mobiles and your server.

I originally had this issue under 2.1, and then I tried upgrading to 2.2, and 2.3 snapshot and it doesn’t seem to have affected it.

Openhab usage seems about right:
CPU: 1.98% RAM: 839.9MiB / 15.62GiB

I’ve been connecting to openhab through an Nginx reverse proxy.

I didn’t consider it before now, as the paperui, etc, all seems to work, however on further inspection, when connecting directly to the server neither the BasicUI nor Phone apps have any issues.

Thanks for the hint.

I don’t suppose you have any experience with nginx & openhab?

Not enough experience to help. I had it running that way for awhile but haven’t for over a year. I have OpenVPN set up and my phones connect when ever I’m not on my home network. In a pinch I’ll connect through I’ve no recent experience with nginx and when i did run with it I never experienced any problems.

Same for me - only a problem when connecting through nginx

In the end I fixed this by using the recommended nginx server options in the openhab documentation.

1 Like