Issues with Visual Studio Code

Tags: #<Tag:0x00007f617c2a2df0>

Hey Guys,
i´ve just started working with openHAB and I wanted to write some rules…
The problem is Visual Studio.
When i´m trying to grab my items and things via the openHAB extention this error appears:

Error while connecting to openHAB REST API. write EPROTO 4092282824:error:100000f7:SSL routines:OPENSSL_internal:WRONG_VERSION_NUMBER:…/…/third_party/boringssl/src/ssl/tls_record.cc:242:

The only thing I did so far was editing the settings.json as follows:
Anmerkung 2020-09-07 210158

I´m looking forward to your suggestions.

Hi @DasJan,

Are you sure that 8080 is the configured https port and do you want to access openhab through https on purpose?
The default port for https should be 8443, if you didn’t change it.

If you don’t want to access openhab via https you could remove the https:// from the openhab.host setting and just use the ip with 8080 as openhab.port

It works, thank you very much.
When do I use the https access?

1 Like

Sorry for the long answer in advance. :smiley:

Simple answer:
When you want your openHAB instance to be secured with an encrypted connection.
There is no “you need it for this function” as far as i know.
Everything should work with http too.

As this answer may not be that helpful:

So should i use https or not?!

This depends on your personal preferences.
We have many users that prefer secure communication for their smarthome base system, but also others that would say, a secured home network in general is enough.

Personally i would say, https should be prefered if you are willed (and able) to set it up properly.
If you are not (yet) familiar/interested in the topic already, it might not work well and will be frustrating.

Anyway https should be something on the to do list on a long term running smarthome list some day, in my view.
We have a good tutorial for solving this problem with nginx as a reverse proxy in our documentation.

1 Like