Items added from textual definition don't show up in model

I am finally migrating from my old text file .items to the newer gui style with semantic models.

I tried adding some items using the “Add Items from Textual Definition” which seemed ok until I went to my model…and they don’t show up! If I select the group/equipment they belong to, my items are listed.

I imported these items:

and the parsing was ok.
My model shows:

Indicating no items belonging to Modes. Note that “Show non-semantic” is selected

However, if I go into “Modes”, the members show up.
I see this:

I’m probably doing something stupid, cause I can’t find any posts relating to this. Any idea what, if anything I am doing wrong?
I’m running 3.3.0


Guess: you have model items defined via both the UI and configuration files. If this is the case then unpredictable things happen. You need either all UI defined, or all configuration file defined.

The items themselves do not have any semantic tags. Just because an item is a member of a semantic group it is not yet part of the model. An item must also have one or more appropriate semantic tags.

To be honest, the best advice for you at the moment is, if you wish to use the semantic model don’t try to get there from your item files. It will most likely take you days of frustrating troubleshooting whereas simply using the efficient item creation functions built into the model will take a couple hours at most even for a large OH setup.

I might have to. I was trying the different method of adding items. I did everything from the model for all of my physical items (Add equipment from things) which worked great, but I thought I would try this for my “virtual items”

I realize I don’t have semantic tags for them, but they should still show up in the model if I enable “Show non-semantic”.

Nope. I removed all my .items files from the system before stating this journey. unless It has something to with persistence. I’ve also restarted OH

Nope. Not with what you’ve set up. If you take them out of the semantic group (or maybe put them all into another group that is non-semantic, not sure if that will work in this case) then they will show up in the bottom part of the model list when you enable “Show non-semantic”. But right now the system is essentially malformed because it is trying to put those items in a semantic group but cannot because they don’t have any appropriate tags.